Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

"We couldnt download the windows mixed reality software"

Same error over and over, I can not get past it even after reinstalling windows 5 times now.
Not on a metered internet connection. Tried 3 different connections, wireless and wired, makes no difference.
Whats the deal ?
Surface Book 2 15" 16gb ram gtx 1060 256gb ssd
Samsung Odyssey
Windows 10 Pro 16299.251
Windows is up to date.

Please help :/

Answers

  • Bueller.......Bueller........Bueller........Bueller..........Bueller.....

  • Hi KirbyOfOcala,

    This is known issue with the latest update patch, and we're working to resolve it in a subsequent update.

    https://support.microsoft.com/en-us/help/4090913/march5-2018kb4090913osbuild16299-251

  • Martin123Martin123
    edited September 2018

    I have Windows 10 version 1803 version 17134.320 and am experiencing the same issue.
    Have tried reinstalling windows, updated all drivers, checking internet connection, troubleshooted windows update, sfc/scannow. etc. No difference, still cant get past the "Try Again" screen.
    Acer Aspire GTX1060, I7-8750, 16GB, 128GB SSD
    Acer AH101 mixed realty headset
    NOTE. the headset does work on friends lower spec older Acer with same windows build.


    SOLVED The problem was a registry issue as described by Fireplug. I changed the DWORD value to 1 and the software downloaded.


Sign In or Register to comment.