Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

USB 3 problems with Mixed Reality and Windows 10

I have a HP Mixed Reality Headset that worked fine up until a few months ago, I haven't been able to get it to work even thought I get all the ticks in the Mixed Reality Portal,

it now tells me to check if it is plugged into a Superspeed USB 3.0 port, which it is!

and the Device Manager indicates for the Mixed Reality devices that there is insufficient USB Device Speed : 2

even though the Device Manager indicates for the Universal Serial Bus devices that it is working properly

also noticed that the connector at the headset gets really hot.

My motherboard is an MSI X399 Gaming Pro Carbon AC, so the spec's are good, wondering if there has been an update that's causing this issue, getting terribly frustrated, please help.



  • Options

    Have you tested to change another USB 3.0 portal like plugging it into motherboard's port instead of chassis's ?

  • Options

    Hi Akira,

    Yes, I have tried every USB 3.0 port, updated all drivers, uninstalled and re-installed drivers etc.

  • Options

    I have this same problem. My headset worked the first time I used it, but now it reports the error mentioned in the first post. I have two USB 3.0 external hard drives that I am able to connect to the USB ports and they all report USB 3.0.

    I can see under device properties, where several items are listed such as Generic USB Hub and three instances of HoloLens Sensors, there is one item listed as "Realtek USB2.0 Audio". Is it possible that that could cause my computer to treat the headset as a 2.0 device? It seems that the USB slots are all 3.0 capable and the issue is with the headset only.

  • Options

    I ended up getting a new headset and that resolved the issue. I guess it was a hardware defect.

  • Options
    edited May 2018

    Wold be nice if someone from Microsoft would get on here and tell us how to fix this problem. My headset worked fine for 3 months and now all of a sudden I get this error constantly. I used to be able to unplug it and plug it back in and get it to work(come on this should not be like this) but now I get this error every single time so In have a virtual reality PAPERWEIGHT just sitting here doing nothing because of this exact problem the OP is having. Same errors,same everything.

    FIX THIS ALREADY!!!!!!!!!!!!!!!!!!!!!!!!!!

    Opps I did not see the post above this one,Getting a replacement is going to be such a pain in the ***.

  • Options

    i have the same problem with a hp headset and i am unable to get a refund so basically ive been scammed

  • Options

    So i have been talking to someone from microsoft and my problem that is in the checking of the display cable has to do with a problem in the driver of one of my Realtek devices, i recommend everyone to contact microsoft by opening a ticket, it will help you a lot understanding the problem

Sign In or Register to comment.