Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

MR toolkit Motion controllers not rendering in app on Initial launch ?

EvoxVREvoxVR
edited March 2018 in Q&A and Discussions

Hello everyone I am using the latest version of the Mixed reality toolkit (2017.2.1.3) in unity 2017.4.0f1 . In my current setup the Motion Controllers are attached to a static Camera prefab which is placed in the very first scene .

Whenever I make an app package and launch it for some reason upon initial launch the controller models are not rendering in the environment , however if I press the Microsoft button on the motion Controllers and exit the app then re-enter by selecting the already open app the motion controllers render perfectly fine .

I tried running the example motion controller scene and in editor it runs perfectly fine but when I launch that as the initial scene in my created .appx package the are white cuboids appearing in the same space the motion controllers should be rendering.

Ultimately my question is has anyone else encountered this issue with the tracking / rendering of the controller models on the initial launch and can anyone offer a solution ?

Answers

  • Please try to build with 2017.2 version Unity3D. 2017.4.0f1 is still a test version so that you may encounter problems like that.(I cannot even build 2017.3 version but everything is fine in 2017.2)

Sign In or Register to comment.