Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

WACK submission to store Failing due to .dll errors , any ideas?

Hello Everyone I am submitting an app to the Microsoft store and Am now encountering an issue with some of the compiled libraries included in my project. We've built our app in the unity Game engine and are using the Holotoolkit in our project as well . Does anyone have any Ideas on how to manage/ fix this ? The following are the errors displayed on our WACK submission.

 Error Found: The supported APIs test detected the following errors:
    API ExecuteAssembly in uwphost.dll is not supported for this application type. Relay Cars.exe calls this API.
    API DllGetActivationFactory in uwphost.dll is not supported for this application type. Relay Cars.exe has an export that forwards to this API.
    API CreateFastTexture2DFromAssetPath in __internal.dll is not supported for this application type. Assembly-CSharp.dll calls this API.
    API DeleteFastTexture2DAtTextureID in __internal.dll is not supported for this application type. Assembly-CSharp.dll calls this API.
    API RegisterFastTexture2DCallbacks in __internal.dll is not supported for this application type. Assembly-CSharp.dll calls this API.

Best Answer

  • jjenningsjjennings
    edited May 2018 Accepted Answer

    It looks like the source of the issue came from me not enabling the checkbox for " Compile with .Net Native Tool Chain" option in Visual Studio . I enabled it for both my x86 and x64 builds and the issue was fixed. Upon cleaning and rebuilding my solution the next build was fine.

    I also happened to have a FastTex2D script that carried over from our iOS version which I had to delete and remove. That's what references the register, delete and, create 2D texture function.

Answers

  • jjenningsjjennings
    edited May 2018 Accepted Answer

    It looks like the source of the issue came from me not enabling the checkbox for " Compile with .Net Native Tool Chain" option in Visual Studio . I enabled it for both my x86 and x64 builds and the issue was fixed. Upon cleaning and rebuilding my solution the next build was fine.

    I also happened to have a FastTex2D script that carried over from our iOS version which I had to delete and remove. That's what references the register, delete and, create 2D texture function.

Sign In or Register to comment.