Windows 10 April 2018 Update (RS4) rolling out via Windows Update starting June 26

MattZMattZ admin
edited June 8 in Questions And Answers

The next OS for HoloLens is available for download and we need your help. In the coming weeks we will deploy this update to all users, and would appreciate you downloading it now in order to help us validate deployment. Please install the update on a few of your devices and validate your scenarios prior to the update being rolled out to all your users and devices. The update will automatically be delivered as a mandatory Windows Update starting on June 26.

This update will provide a number of great benefits like improved Unified Endpoint Management (MDM) for IT administrators, research mode for developers, and easy file transfer. For a detailed description of the new capabilities, please see our Windows 10 April 2018 Update page.

Here’s how to do a manual install now:
Note: Manually installing the Windows 10 April 2018 update will delete your personal files and settings.
1. On your PC, install the latest version of the Windows Device Recovery Tool (WDRT).
2. Open WDRT, and plug in your HoloLens to your PC using the micro-USB cable it came with. Select Microsoft HoloLens when it appears on the screen.
3. On the next screen, select Install software, and follow the instructions to complete the installation.

Thanks,
Matt

Tagged:

Comments

  • Peter_NZPeter_NZ ✭✭✭

    Speaking from experience we did need to update our software iron our a couple of minor bugs that appeared with RS4. So if you haven't so already I would run up your software on RS4 to make sure it works as expected.

  • MattZMattZ admin

    @Peter_NZ anything specific you ran into? I'd love to update the notes for devs at https://docs.microsoft.com/en-us/windows/mixed-reality/release-notes#known-issues and add anything else you may have found!

  • Peter_NZPeter_NZ ✭✭✭

    @MattZ In our case we had the following issues:

    Issue 1:
    The following lines of code would fail about 1/10 times:
    StorageFolder storageFolder = Application.Current.LocalFolder;
    StorageFile xmlFile = await storageFolder.GetFileAsync("filename.xml");
    XmlDocument xmlDoc = await XmlDocument.LoadFromFileAsync(xmlFile);  // Never returned

    But the following does work 100%
    StorageFolder storageFolder = Application.Current.LocalFolder;
    StorageFile xmlFile = await storageFolder.GetFileAsync("filename.xml");
    System.Threading.Tasks.Task.Delay(200).Wait();
    XmlDocument xmlDoc = await XmlDocument.LoadFromFileAsync(xmlFile);

    Issue 2:
    Also we used to have multiple coroutines to update some of our UI elements. It worked 100% in pre RS4. But with RS4 we had timing issues which some of the UI elements stopped populating. We put this all in the one coroutine (as it should have been from the start) and it all worked 100% with RS4.

  • edited June 26

    It says I cannot update. I tried 3 times.

    Error code 0x80188306

    edit: this seems to be a known issue with the update

  • So far all but two of our apps have lost their icons in the menu and about 3 of them crash on first time launch then seem to run normally.
    Incase we find more issues, how do you manually install the previous update? I cannot find documentation on where to download them to use WDRT to push an old OS manually.

  • Is video recording during using Vufoia not available on RS4? Actually, previous version of HoloLens works without any problems. On RS4, the video recording stop as soon as I turn on Vuforia.

  • We own 3 Commercial Suite HoloLens devices. After the forced Windows Holographic update this week, we can no longer disable the sign-on option on any of the ones that got updated, meaning that even though the Sign-on option is set to OFF under Settings > Accounts > Sign in options > Require sign in, we are forced to log in every time the Hololens restarts or wakes up. This is extremely disrupting as we use these devices in Kiosk Mode to show customers/business partners our work, and it's very frustrating and time consuming to have to sign-in every time we start or wake up the device even though the sign-in is specifically disabled in Settings on each HoloLens device. Any suggestions how to fix this?

    Thanks!

  • windows 1803 (OS Build 17134.345) October 2018
    version for Windows Mixed Reality. For Samsung latest you need an Insider version 18386 track at least.

    HP WMR headset works fine with windows 1803 (OS Build 17134.345) October 2018

    Please note that the Fast track is potentially unstable
    but you cannot have everything!!!.

    If have a corporate pc Office 365, get another pc from Corporate IT. Boot Professional from the Windows 10 Media installer USB
    Format the hard disk and install Windows Pro connect to the wireless router, login to your MSA account, the windows 10 pro will install

Sign In or Register to comment.