Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Shared TapToPlace issues

Hello, the problem I'm having is a little complicated as I tried different ways of solving it ending up with different issues, so I'll try to break this down.
Using Unity 2017.4.1f1.

1. Mixed Reality Toolkit (Example)

I implemented this specific package containing the standard toolkit and a few examples, then proceeded to open the SharingTest scene. It had a missing script which I replaced with the TapToPlace script (I supposed that to be the missing script, since there was an Interpolator script as well), I then built it and connected two HoloLens. The outcome varied every time I rebuilt/restarted the application, giving me either:

  • No connection to the Sharing Service app
  • Only one HoloLens connecting
  • Both connecting with desynced anchor
  • Both connected but anchor kept going back to the original position no matter who tried to move it

2. Mixed Reality Toolkit (NO example)

After the failed experiment with the example scene, I tried making my own example adding the scripts I deemed necessary and ended up having a scene where both HoloLens could see what was going on but the scene was not synced correctly and all of the sudden the objects I used for testing purposes, with a TapToPlace script, kept going back to their last position letting no one move them. I only tried this twice

3. MR Sharing 240 tutorial

At last, I tried following this specific tutorial and managed to set up the scene correctly, but I had two recurring problems:

  • Out of 10 tests, the app connected only _once _to the Sharing Service
  • Out of 10 tests, I managed to be able to place the Hologram only once (not sure if it was the same time the connection worked)

I am now at a complete defeat. I've been trying for days with no success and it seems no one is interested or just isn't having these issues. What would you suggest?
My final purpose is to create an app with a Main User _and a _Spectator User that allows me to:
1. Open a scene with an object instantly placed by the main user that the spectator/s can see
2. Open a scene where the main user spawns and moves objects which the spectator/s can see in real-time or with some slight delay

Scenes should always be synced either manually or automatically.

Thank you for your time.

Sign In or Register to comment.