Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

SpectatorView preview for Unity 2018.2+

Hello everyone,

I am using the spectator view preview version with the iphone. I got it to work in Unity 2017.4.12.f1


I downloaded the latest mixedrealitytoolkit htk_development branch.

I copied the dll files into Assets\HoloToolkit-Preview\SpectatorView\Plugins\WSA\x86

Opened up the spectatorViewExample scene, built it for the hololens, then the iphone in the same session. Got it to work great!

My issue is that I have to use unity version 2018.2.7f1 to incorporate it into another project. I tried following the same steps for this version of unity. When I build it to the hololens, I get the unity logo, and then nothing afterwords. I looked at the errors, and it appears the SpectatorViewPlugin.dll is not being found or loaded. I made sure I put it in the same exact place, and I made the build settings all the same.

I was wondering if anyone had any ideas of what I could try to get it to work.



  • Figured it out. In the new version of unity, you can't just add the dll files, you also have to navigate to them in the unity editor, click on them, and apply the settings. Now it recognizes the dll files and the app runs!

  • Have you had other compatibility issues using Unity 2018.2.7f1 and the HoloToolkit?

  • Hi daviddesign,

    how did you get it to work with Unity 2018? I'm stuck with the following error:

    'MarkerDetection.exe' (CoreCLR: CoreCLR_UWP_Domain): Loaded 'C:\Data\Users\DefaultAccount\AppData\Local\DevelopmentFiles\MarkerDetectionVS.Debug_x86.cd\System.Diagnostics.StackTrace.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    Exception: The method or operation is not implemented.
    Type: System.NotImplementedException
    Module: WinRTBridge
    AdditionalInfo:MarshalFirstFieldIntoNativePtr type: UnityEngine.XR.WSA.WebCam.PhotoCaptureFrame
    at WinRTBridge.Marshalling.MarshalFirstFieldIntoNativePtr(Object instance)

    (Filename: Line: 0)

    ArgumentNullException: Value cannot be null.
    Parameter name: _unity_self
    at UnityEngineProxy.InternalCalls.PhotoCaptureFrame_CUSTOM_GetDataLength(Object self)
    at UnityEngine.XR.WSA.WebCam.PhotoCaptureFrame..ctor(IntPtr nativePtr)
    at UnityEngine.XR.WSA.WebCam.PhotoCapture.InvokeOnCapturedPhotoToMemoryDelegate(OnCapturedToMemoryCallback callback, Int64 hResult, IntPtr photoCaptureFramePtr)
    at UnityEngine.XR.WSA.WebCam.PhotoCapture.$Invoke10InvokeOnCapturedPhotoToMemoryDelegate(Int64 instance, Int64* args)
    at UnityEngine.Internal.$MethodUtility.InvokeMethod(Int64 instance, Int64* args, IntPtr method)
    (Filename: Line: 0)

    Any ideas?

    I'm using 2018.2.5f1 and also tried 2018.2.12f1, with the same error. Unity 2017 seems to work better, but I'd rather not go back.


  • Update: I tried with 2018.1.7f1, and that seems to work, the above error is gone. Still, I'd rather stay with 2018.2.

  • Sorry I have not checked this in a while! Yes, I found that issue too. I had to revert to Unity 2018.1.9. The camera doesn't work in 2018.2 and they still haven't fixed it!


    Sorry for the confusion! I was excited when the dll files were recognized and I jumped the gun. Then when I tested on the Ipad I got that error.

  • Yea! I wish I could use 2018.2 too, it took forever to downgrade. Hopefully they fix that bug soon.

  • @CCorona

    No, not that I can think of at the moment. Everything else I have used seems to have worked.

  • @daviddesign I just couldn't get it to work with Unity 2018.1 both the release 2014.2.0.0 or the latest dev branch. By any chance could you zip your project folder (only the sdk, of course, nothing personal) and share it with us? I noticed a few other users with the same issue :(

    Thanks buddy

  • sure, here it is

    you probably need to replace the dll files with your own

Sign In or Register to comment.