What are the requirements to build apps on hololens successfully with IL2CPP as a scripting backend?

edited October 2018 in General

I switched from .NET to IL2CPP due to .NET being depricated and so on.
Sadly i can't deploy on device in Visual Studio. There is always a Pop Up with "These Projects are outdated." Why are my new Projects outdated?! And how can I resolve this issue? If i create them new due to the pop up asking for it, i always get an error about "standard collector bridge".

Answers

  • edited December 2018

    I've done successful builds and deploys using the following settings:
    Device: HoloLens (Any Device also has worked for HoloLens)
    Build Type: D3D
    SDK: Latest(10.17763.0)
    Build and Run: USB Device (this appeared when I installed unity with UWP support)
    Scripting API: .NET 4.x equivalent
    Backend: IL2CPP

    After you build the solution will have a device option in the start debugger I believe it defaults to Remote Device but switch it to Device, connect the HoloLens with USB, select x86 as Architecture

    things to keep in mind make sure Win10 Holographic is updated to the same SDK you are using, and it may ask you to request a pin in 1st deploy you can get the pin in the HoloLens' Developer Settings

Sign In or Register to comment.