Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Suddenly, deployment to HoloLens does not work.

Error DEP0001: Unexpected Error: -198894506
App deployed OK this morning. I added a script and got the above error. Deployment to Emulator works. I tried redeploying a previously deployed app with no changes and got the same error.
Does anyone have an idea on what has happened here?


Best Answer


  • @moontube a DEP0001: Unexpected Error often happens when wireless connection is lost to the Remote device if the HoloLens goes to sleep, gets turned off, switched out etc...

    If this is the same thing, the resolution is to close the Visual Studio project (shut down Visual Studio) and reopen the project. Typically it will redeploy just fine after the restart of VS (until such time as the device goes to sleep from inactivity again).

    FYI... there is a setting in the HoloLens device's setting that defaults to 3 minutes that you can extend to a longer period at the expense of battery.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Thanks for the suggestion Holosheep, but this is happening with a direct USB connection. Closing Visual Studio before redeploying does not help. I still get the same error. Any other thoughts?

  • This is probably unrelated, but in the process of trying to fix this I unpaired my device. It now says number of paired devices 0. I clicked the Pair button and it gave me a code, but I don't know where to enter that code. I get the DEP0001 error before Visual Studio has a chance to ask me for the code.

  • @moontube while supporting the participants at the Seattle Hackathon, there were a number of cases where the actual USB connection to the laptop from the device was acting up.

    You might want to double check that your pc is correctly recognizing the connection. For example, when you unplug the USB from the pc and plug it back in do you hear the plug-n-play new device sound? Does the HoloLens show up in your Settings | Devices | Connected Devices list?

    With those machines that had temperamental USB buses (or whatever issue with USB) if it was strictly a USB issue, we would have better luck connecting Remote over wireless (except for our wireless network was heavily overloaded). If wireless connection didn't work, we would then move on to double checking that all the correct tools and versions were installed, that the project path names were short without spaces etc.. etc..

    Note, I seem to recall that Visual Studio also needed to be restarted if a USB connection to Device was lost or if the device went to sleep, I don't think that was just the wireless Remote scenario.


    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • HoloLens shows up as a connected device, so that shouldn't be it. I have been exiting Visual Studio before every new attempt, so that shouldn't be it. From your comments, it seems that this error is a catch all for just about anything it doesn't like. I am stuck.

  • @moontube I gather you have already tried the shut everything down and reboot and restart approach as well.

    Perhaps you could share a screenshot of the error in your Visual Studio environment incase there is some subtlety that stands out to someone on the forums.

    You mentioned that the only thing that was different from when things worked to when they didn't was that you "added a script". Can you tell us anything more about that change in case it helps?

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • I tried rebooting again just to make sure, starting everything from scratch. Same error message. Aside from the app which I added a script to (Origami, adding the TapToPlaceParent script), I also get the same error when trying to redeploy a previously deployed app that just created a simple cylinder hologram, with no scripts involved. That script still runs on my HoloLens as does a previous iteration of Origami that does not yet include SpatialSounds or SpatialMapping. The iteration with spatial mapping deploys to the Emulator, although for some reason the simulated gaze does not move things around with either the mouse or the keyboard keys.

  • ahillierahillier mod
    edited June 2016

    A similar error was reported earlier:

    I would suggest closing VS and Unity, deleting everything in your Unity project folder except for the 'Assets' and 'Project Settings' folders, load your project in Unity and then rebuild everything again.

    Also, please double check that you have the latest update installed on your HoloLens (go to Settings > Update & Security > Check for updates), have the latest update for VS installed, and that your PC and HoloLens both have 'Developer mode' turned on (Settings > Update & Security > For developers). Finally, verify that you can connect to your device via the Windows Device Portal.

    If this error continues to happen when deploying with 'Device', try switching to 'Remote Machine' instead to see if you can get a better result.

  • Hi ahillier,

    I know that I have the latest update and am in developer mode, because all this stuff worked before. I have also built from scratch. Just now I built the holographic 240 app from scratch and ran it on the Emulator. It worked there. Then I tried deploying to Remote Machine rather than Device. The error message I got was different. Here it is:

    Severity Code Description Project File Line Suppression State
    Error DEP6957 : Failed to connect to device '' using Universal Authentication. Please verify the correct remote authentication mode is specified in the project debug settings. 0x8007274C: The network event being waited on triggered an error. SharedHolograms

  • I tried disconnecting the HoloLens from the PC. After that I have a new IPV4. However, when I tried to redeploy it still tried to deploy to How can I tell it the new IPV4?

  • Hi, any luck with this error? I have the exact same problem and have tried all of the solutions. I even had the microsoft devs at the boston hackathon try and get it deploying but no luck. I can successfully deploy to the hololens over wifi, but keep getting the same error as moontube when deploying over usb. I'd keep deploying over the wifi connection, but it is not always fast enough to handle the pushes and they take significantly longer to deploy than over usb.
    the hololens is detected as a device on usb within device manager as well.

Sign In or Register to comment.