Store reject submitted app couple of times citing reason DirectX 10 error

Hi folks,
I am trying to submit an app but it has been rejected couple of times citing reason that Store testers failed to install the app. I changed some properties (removed immersive headset as minimum requirement, but no help). Finally on contacting store help, I got reply that it is a DirectX 10 error and I was sent the attached snapshot.

I am able to successfully install the side loaded version of the same app package submitted to store on our all HoloLens and it works as expected. This works for all the rejected app for me. The app is built in Unity3D with D3D.

Could you please let me know why DirectX 10 is being mentioned in system requirement? If it is indeed required for HoloLens, what we need to do on the App side? I already have another app on Store for HoloLens and that was accepted on store. I am following same procedure for this app as well. The only difference is that here I am using IL2CPP as scripting backend and not .NET as that has been deprecated in Unity for UWP apps.

Have anyone faced similar issue? This is driving me crazy as it has been going for almost a month now!
Thanks.
R.

Best Answer

  • HoloholicHoloholic
    Accepted Answer

    So, we figured out what the issue was with good support from Mixed reality development - 1:1 support. The problem was that I was using Unity 2018.2.4f1 with "Auto Graphics API" (https://docs.unity3d.com/Manual/GraphicsAPIs.html) checked (default value). This automatically generates StoreManifest.xml file inside Unity Data in VS project (with IL2CPP) during built with system requirements for DirectX 10 version. This apparently is a strange behavior for Unity 2018.2.4f1 version. I haven't checked on any other latest version of Unity. This file is not generated for Unity 2017.4.14f for which Microsoft have LTS. So, if anyone is using newer version of Unity: there are possibly two solutions:
    1. Uncheck Auto Graphics API and select Direct3D11
    2. Delete StoreManifest.xml in case you don't have any store dependency.

    Cheers!
    R.

Answers

  • HoloholicHoloholic
    Accepted Answer

    So, we figured out what the issue was with good support from Mixed reality development - 1:1 support. The problem was that I was using Unity 2018.2.4f1 with "Auto Graphics API" (https://docs.unity3d.com/Manual/GraphicsAPIs.html) checked (default value). This automatically generates StoreManifest.xml file inside Unity Data in VS project (with IL2CPP) during built with system requirements for DirectX 10 version. This apparently is a strange behavior for Unity 2018.2.4f1 version. I haven't checked on any other latest version of Unity. This file is not generated for Unity 2017.4.14f for which Microsoft have LTS. So, if anyone is using newer version of Unity: there are possibly two solutions:
    1. Uncheck Auto Graphics API and select Direct3D11
    2. Delete StoreManifest.xml in case you don't have any store dependency.

    Cheers!
    R.

Sign In or Register to comment.