Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Speech recognition not working on Hololens with Unity

Hi all, I'm trying to get speech recognition working on the Hololens with my Unity project.

Let me preface by saying that the "microphone" option in the UWP player settings is enabled, and "Hey Cortana" works on the Hololens.

At first, I wrote my own script using UnityEngine.Windows.Speech, keywordRecognizer, etc. (I presume this is how the HoloToolkit scripts do it?) Problem is, it worked fine in Unity, but was completely unresponsive on the Hololens.
So, I scrapped everything and set it back up using the official HoloToolkit scripts, "speechInputHandler" and "speechInputSource". Once again, it works perfectly in the Unity editor, but does nothing when deployed to the Hololens.

Seeing as I'm now using the scripts provided directly by Microsoft, yet still nothing is working, I'm at a complete loss. Any help would be greatly appreciated.

Tagged:

Answers

  • Are you trying to accept a pre-defined list of voice commands or free form text (like a dictation). For Keywords, I am using the KeywordRecognizer class and passing in a list of commands and an OnPhraseRecognized delegate which responds to them. For free form text I am using the SpeechRecognizer class.

  • kkalinakkalina
    edited December 2018

    Thanks for the response; I'm using predefined keywords, with the KewordRecognizer class.

    I've actually solved the issue by switching to a different hololens. So this seems to be a device problem of some sort.

Sign In or Register to comment.