Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Lots of errors loading a Unity project into Visual Studio... would appreciate your help!

I am not a programmer but greatly appreciate any advice you can give. I have been following tutorials online about how to display 3d objects in hololens. Before about a week ago everything ran smoothly: I would upload a .fbx file as an asset, build a solution in unity, open it with visual studio, and click start without debugging and it would run in the hololens. Now I annot even get a basic cube to work.

I follow everything as it is laid out in the tutorials: I open unity, add an empty game object, right click and add cube, save scene, build settings, add scene switch to windows store, universal 10, d3d, check unity C# projects, and click build.

When I find the .sln file and open in visual studio, I get 135 errors showing in the error list.
The errors are all either

CS 0234 - The type or namespace name 'Runtime (different file name for each error)' does not exist in the namespace 'System' (are you missing an assembly reference?)

CS0246 - The type or namespace name 'FrameworkDisplayName (different file name for each error)' could not be found (are you missing a directive or assembly reference?)

CS 0518 - Predefined type 'System.String (or System.Object or System. Void)' is not defined or imported.

CS0012 - The type 'object (different file name for different errors)' is defined in an assembly that is not referenced. You must add a reference to assembly 'mscorlib, Version= 4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c56193e089'.

There is one CS1545
Property, indexer, or event 'CoreApplication.Suspending' is not supported by the language; try directly calling accessor methods CoreApplication.add_Suspending(EventHandler)' or 'CoreApplication.remove_Suspending(EventRegistrationToken)'

These errors come up despite that I followed tutorials closely. Thank you all for your assistance with this.

-AP

Best Answers

Answers

  • I've seen similar errors when trying to build if Nuget didn't do a package restore before building the project.

    Can I ask what version of Unity and Visual Studio you are using?

  • Hi @apines, what has changed in the last week? Did you get a new PC? Is it possible that your Visual Studio setup changed even if you are using the same PC? One option you can try is to remove all Unity generated files ("App" dir?) and try rebuilding again. If that doesn't work, then the easiest solution is probably just uninstall everything (Visual Studio/Win10 SDK and Unity, etc.) and re-install them. Since you said it was working a week ago, the best option for you is "go back" to the original state. ~h

  • Thank you @holodoctor and @jowitt for your suggestions! So I am using the bet version of unity (5.4.0b22) and Visual studio community 2015. I do not believe that anything significant has changed with my computer in the past week. I tried uninstalling and reinstalling unity and visual studio, but now the scene wont even build in Unity. I get the error: UnityException: Build assembly not found. I tried repairing Visual studio, but got the same error. I am going to uninstall and reinstall again, so I'll let you know how that goes. Thank you again for your assistance; it's nice for a beginner like me to have such a responsive forum.

  • apines, is it possible that you only installed the Unity Editor package and not the UWP editor support?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • AlexDAlexD ✭✭✭

    The latest HTP version of Unity is 5.4.0b20. Make sure you always install the HTP (HoloLens Technical Preview) version of unity and not the latest Unity.
    Here's the link.

    Also, as @Patrick mentioned, make sure you install both Unity and the UWP Runtime (in this order) - It does not matter you installed UWP before, whenever you update / reinstall unity, you need to reinstall the UWP runtime associated with that Unity version.

  • I have been playing around with it all day, but am unfortunately still getting the same error: Platform assembly not found.

    I tried uninstalling virtual studio and Unity, reinstalled virtual studio 2015 and tried both the new beta 22 and beta 20 from the archive, both of which gave me the platform assembly not found error. For beta 20, I got the uwp runtime from a link that shows up with the windows store selection in build setings, as the uwp runtime on the website was only for beta 22. On beta 20, the list of virtual reality SDKS in player settings is empty, ie windows holographic does not appear.

    Thanks @Patrick, @AlexD, @jowitt, and @holodoctor for all of you help. I don't really know what I could try from here and would really appreciate any further advice.

    AP

Sign In or Register to comment.