Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Trouble with UWP Hololens app and firewall

Hello. I have a UWP application (call it "client") running on Hololens and a WPF application (call it "server") running on a remote laptop. They are communicating through the wireless LAN via SignalR. They are only able to communicate successfully if I disable the Windows Firewall completely on the laptop. Both the UWP application and the WPF application are projects in the same solution being built on the laptop. After being built the UWP application is deployed from the laptop to the Hololens, at which point I test communication between the two.

I'd like to allow the UWP app that's being deployed to the Hololens to be able to communicate with the laptop without disabling the firewall on the laptop and so I tried to add the UWP app to the list of applications allowed through the firewall on the laptop. To do so, in "Windows Security" I clicked "Allow an app through the firewall", clicked "Allow another app..." and then navigated to the debug build executable of the UWP application in the solution folder on the laptop. I checked both "Private" as well as "Public" check boxes just to make sure. I then did the same for the WPF application as well. Unfortunately they still cannot communicate when the firewall is on. Even after adding both UWP & WPF applcaitions to the list of apps allowed through the firewall, they can still only communicate if I disable the firewall entirely.

What am I missing here and how can I get this to work?
Thank you in advance.

-L

Tagged:

Answers

Sign In or Register to comment.