Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Unable to download HoloLens app from Microsoft Store. Possible Unity version connection?

We've been running into problems after publishing our app to the Microsoft Store. The app is successfully published, but fails to download. After investigation, we assume some issue with a newer version of Unity.

Steps to reproduce
1. Open the app page in the store
2. Click on "Get"/"Install"

Expected result
• Application installs on a HoloLens device

Actual result
• Application does not start downloading (seems to get stuck initializing the download)
• Store page shows "You own this app" plus an inactive "Install" button
• When choosing 'Install on my devices', a pop up appears saying "Try that again.
Something happened on our end. Waiting a bit might help."
• We've found a long workaround, that worked on only one specific device.

Tests we did
• We rechecked all the settings and configurations several times.
• We tried to download on different HoloLens devices, and through different networks
(also 'clean' devices on which the app hadn't been installed before).
• We ruled out that the problem is machine specific by setting up the listing from a
different machine, as well as building on a different machine and publishing through a
different machine.

Findings
• We started several test listings and tried to publish stripped down versions of the app
with different versions of Unity: 2018.2.14f1, 2018.3.0f2, 2018.1.0f2. The 2018.2 and
2018.3 builds failed, the 2018.1 builds downloaded without any issues.
• Building the same 2018.1 package that was successfully published, but this time with
an IL2CPP scripting backend, resulted in the store not accepting the package, indicating
that it lacked packages for all selected device families. However, after switching the
backend on the same project back to .NET, publishing worked again.

Questions
• We're not aware of any Unity 2018.2 apps successfully published through the Microsoft
store. We do know of at least one Unity 2018.3 app being successfully published. Did
anybody run into similar issues when publishing apps to the store with more recent
versions of Unity and maybe IL2CPP?

Comments

Sign In or Register to comment.