Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

dlls not found for builds

Hi,

I've come up with an issue when building the tutorial Holograms 100 project. As instructed, I imported the project from Unity to VS, modified the appxmanifest file, changed the target, and then run it with Start without Debugging, which gives me errors in attached image.

As you see the issue is that somehow the dll files is not generated at the right place. For example as I look into the path for the first error, the dll file is actually in a Unprocessed file under Debug. And every time I rebuild it the dll will just automatically reappear in that file. I am guessing VS created this Unprocessed thing and put everything not recognized into it. but why? Is it because VS is not configured correctly? Interesting thing is that for the third error (in Assembly-CSharp), there is no such Unprocessed file under Debug, and still no dll file found. I am totally unsure why this is happening.

I tried searching online and unchecking+rechecking boxes under build option in configuration does not work for me. I believe the last two errors are also relevant to this issue. Any ideas? Thanks for any suggestions.

Best Answers

Answers

  • It looks like you're trying to build for ARM. HoloLens is an x86 device. Change the dropdowns on the top to "Release" and "x86".
  • In addition to changing the build type to x86, you might try right clicking on the solution and choosing "rebuild all". I had that same issue you showed and it helped to rebuild the entire solution prior to trying to deploy to the hololens. YMMV.

  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited June 2016
    Your build path length has exceeded a known bug length .Total length is about 40 characters for example c:\unity\holo210\
    The shorter the better or serialweaver.exe will fail
  • @Jimbohalo10 I created another new project directly under C:\ and now the path is C:\holo100. But it seems that serialweaver is still crashing, and error msgs are similar. I am not is this the right way to shorten the path length you mentioned since it doesn't work.

    I've attached new error msgs and the info in output window. Pretty sure there is length issue based on the index out of range exception, but unsure how to handle it. Do you see other way out of this?


  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited June 2016

    @johnp I cannot see why this is happening, but similar problems in other thread here

    Could you try building the code given in my Tutorial: Debugging with Holograms 211 with update code library

    This is very detailed and would avoid my of the pitfalls that earlier code has given HoloLens developers. This would test your development environment and make troubleshooting easier.

Sign In or Register to comment.