Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Unable to connect to device to load sample app

Trying to do the Hololens tutorial, but am unable to connect to the device from Visual Studio in order to deploy. I have tried both the IP address (remote device option) as well as connecting via USB. I have the developer options turned on from the device settings, but still can't even connect to the http://127.0.0.1:10080 device portal. Any thoughts? I am on the same network (home, so no extra corporate security blocking things) and I do get a valid home network IP address.

Answers

  • I've seen some instances where a firewall blocked access to the device.

    Can you connect to the device portal using the device IP address?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • just tried and I am able to connect to the device portal using the device IP. I will do some more troubleshooting as to why Visual Studio was unable to connect. Thanks!

  • I was able to get it connected after several tries. It seems to work best when the device is at the windows menu, as it obviously ensure the device is running and awake.

  • ahillierahillier mod
    edited July 2016

    Hi @jdeason23,
    Have you installed Update 3 for Visual Studio? There was a bug in the previous releases where deploying to the HoloLens would fail if the device was asleep. That should be fixed with the latest update. Although, out of habit now, I always wake up the device before deploying.

Sign In or Register to comment.