Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

DEP0001 : Unexpected Error: -1988945906

I receive the error 'DEP0001 : Unexpected Error: -1988945906' when I try and deploy to HoloLens.

Developer mode is turned on, however I also cannot connect to the portal. When I try via USB with 127.0.0.1:10080 I get connection refused. When I try via WiFi, I get 'xx.xx.xx.xx took too long to respond.'

The internet connection on the device and on my dev machine are working fine. I'm using VS 2015 Update 3.

Any thoughts?

Tagged:

Answers

  • @Scott is the Device Portal enabled on the HoloLens and have you paired the device?

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • ScottScott
    edited July 2016

    @HoloSheep Device portal is enabled, but the device is not paired. I don't see anywhere to enter the pin to pair the device.

  • @Scott, both Visual Studio and Device portal require you to be paired when connecting over wireless.

    If you point your browser at the device it should at some point ask your for a pin and you can generate that pin from your device by clicking the Pair button.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep

    Thanks for your quick, and helpful, answer!

    This worked for a paired device over wifi. However, I also have a dev machine that has no network installed (intentionally); the USB connection doesn't appear to be working there. I'll test again, but if there's something I may be missing I'd appreciate the feedback.

  • @Scott is your HoloLens showing up in Device Manager and is it triggering the USB device connection sound when you plug it in via USB?

    If the USB connection is working with your HoloLens and your pc, you should be able to connect to device manager over USB by pointing the connected PC's browser at:

    In case it helps, here is a thread from a couple of months ago that explored a number of angles on the issue of checking the connection over USB.

    Interestingly it sounds like the person had success with using a different browser.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Also, the way we communicate over USB looks to the system a lot like communicating over a generic network. I've seen some firewalls (recently AVG) block access to the localhost:10080 address.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Scott I hope you have already solve your problem since July 2016. Today,I had the same problem. If this can help others. I have solve my problem by starting the service: Windows Phone IP over USB Transport (IpOverUsbSvc)

Sign In or Register to comment.