Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

When debugging Mixed mode in VS, loading symbols takes many many minutes

Hi,

I am able to run my unity projects with C# and have them work. However, placing breakpoints in the scripts is not working. I read on this forum that I need to enable mixed-mode debugging (native too) and I did that.

However, now, when the project loads, VS tries to load symbols for all native dlls (there are many of them - ntdll, combase, kernelbase etc) and that's un-cancellable (you don't get the dialog that tells you it's loading, you only see it on the bottom). This process takes about 40 minutes.

How do I tell VS to only load symbols I am actually working on or otherwise debug my unity project w/o enabling mixed mode debugging?

Tagged:

Best Answer

Answers

Sign In or Register to comment.