Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Apps Won't Deploy to Hololens! Please Help!

My app works completely fine with the emulator. I am able to build it to visual studio without a problem. But when I try to deploy to my Hololens, it just won't work. It says the app needs to be deployed directly. No matter what I do the deploying fails.

Answers

  • sptspt ✭✭

    Hmm have you figured it out yet? What method are you using to deploy? The first thing to do is use the portal to the device in your web browser and make sure it connects to the network correctly. Next, make sure the developer mode is enabled in settings.

  • The usb connection method might work better for you depending on your network configuration. See https://developer.microsoft.com/en-us/windows/holographic/using_the_windows_device_portal. Be sure to get the pairing code from the device as well. Plug the device in and make sure it is on. In Visual Studio set to release x86 and device from the dropdown. Then Ctrl + F5. It worked for me.

  • Moving this to Q and A category

  • Make sure to deploy to "Device" if you are connected VIA USB. Not doing this gave me some issues early on.

  • It's a little thing, but I find that if my Hololens has gone into sleep mode and is not fully awake when I deploy, it won't work.
  • I have had problem when I used third party products that uses dll's, after removing these deployment happened again.

    creative mind, free thinker, dreamer, maker, mostly working on games and doodling around with gadgets, Sphered Cazual/Elite/Master of the Universe/Dad/Husband @mariovermeulen

  • I would think that this would be by design, I am not sure you should be able to deploy to a device that is in sleep mode.

Sign In or Register to comment.