Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Holograms 210, can't deploy

When I try to deploy to remote machine (Hololens) i get an error
Unable to activate Windows Store app. Activation request failed File not found
after messing with it a while I found that if I don't follow the instruction
Find the line specifying TargetDeviceFamily and change Name="Windows.Universal" to Name="Windows.Holographic".
and instead leave the line as Universal, it deploys fine. Do the tutorials need to be updated or is something else weird going on?



  • ContextVRContextVR ✭✭✭

    @HeartofBruce I think you're interpreting the instructions incorrectly. That line in Holograms 210 talks about the "Other Settings" tab in Unity "Player Settings" and making sure your "Virtual Reality SDKs" section shows "Windows Holographic". Please see this image for details: http://i.imgur.com/9e87a3X.png

  • For what it's worth, I found that the "Unity settings for HoloLens" section at the top of the tutorial needed to be with the "Build the project" section.

    I did not have the Windows Holographic option available from Project Settings/Player in that early stage of creating the project. I only had the option for Windows Holographic when I accessed Player Settings from Build Settings...

    I use Unity 5.4.0b18-HTP Personal.

  • ContextVRContextVR ✭✭✭

    @wick Did you switch "SDK" to "Universal 10" and "UWP Build Type" to "D3D" in Windows Store Build Settings?

  • I think it's pretty clear. Here are the surrounding lines:

    • In Visual Studio, right click on Package.appxmanifest in the Solution Explorer and select View Code
    • Find the line specifying TargetDeviceFamily and change Name="Windows.Universal" to Name="Windows.Holographic".
    • Save the Package.appxmanifest.
  • @ContextVR Yes, I did.

  • HoloSheepHoloSheep mod
    edited July 2016

    Correction: @wick @HeartofBruce if you connect to the HoloLens in question with Device Portal, does the App tab show a previous version of the project running?

    If so, I would recommend trying to close it from the Device Portal by clicking the X beside it and then redeploying with the TargetDeviceFamily name set to Holographic.

    Next suggestion would be to restart the HoloLens by clicking the Restart button in the Device Portal (and maybe also closing and restarting VS) and trying to deploy with the TargetDeviceFamily name set to Holographic.

    The extra specificity of the TargetDeviceFamily would help with Windows store deployment so that it was clear that it was not a general UWP app therefore shouldn't be tested on tablets etc.., but it shouldn't normally cause errors when you set it and deploy to the device so I would be suspicious that as you said something weird is going on.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep thanks, I am using the emulator though your reply probably helps the original poster of the question. Apologies to @HeartofBruce for veering off course...

  • ContextVRContextVR ✭✭✭

    @HeartofBruce Can you post the error you're getting when you can't deploy?

Sign In or Register to comment.