Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Issues Building Unity Hololens Project: Platform Assembly Not Found


I'm working with the Hololens using Windows 10. I'm just getting started, so I've been following this tutorial to make a virtual cube:

The issue is, when I build the program, I get this error:

I do have Visual Studio 2015 installed, the newest version, with the three recent patches. Looking around, I found several threads with this problem: http://forums.hololens.com/discussion/1082/platform-assembly-not-found http://forums.hololens.com/discussion/1399/unity-exception-platform-assembly-not-found

In one of the above threads, path length was discussed and so I was directed to this thread: http://forums.hololens.com/discussion/comment/3569/#Comment_3569

At first, my Unity path did include spaces and was under my Documents folder. So, I created an entirely new Unity project, set the path directly in my hard drive (d:\hololens..), and made sure each file was succinct and the path short. That did not work; I still got the same error.

So, I moved onto the next problem people had: Visual Studio 2015. The above threads recommended repairing the Visual Studio program files. I went to my Control Panel and updated them, quit the programs, restarted my computer, and tried again. I still got the same error. I haven't tried uninstalling Visual Studios entirely though; I quite literally just installed it on my computer yesterday, and it installed just fine, so would uninstalling and reinstalling even change anything?

One hiccup that occurred when I tried repairing the Visual Studios program files was this:

When I went back through the Control Panel, to repair those two files, the closest versions I found were off by one digit: the final digits on each were a 2 instead of a 0. I repaired those too and restarted, tried again, and got the same error.

At this point, I'm quite frustrated and I don't know what the issue could be. My laptop is set in Developer mode, I have the most current edition of Unity, I've double checked that I've followed everything in the tutorial, and I've done everything except uninstall and reinstall Visual Studios. Any help would be greatly appreciated.



Best Answer


  • @ahillier,

    I completely uninstalled and reinstalled VS and the error went away! Thank you for your help. I still received the same warning from VS about the same two files, same wording as the above photo and everything (which I found weird since those two files should have been removed with everything else -- I used this tool to completely remove VS from my computer: https://github.com/Microsoft/VisualStudioUninstaller/releases).

    Luckily, the original error didn't show up and it seems to be working correctly now.

    Thank you!

Sign In or Register to comment.