Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Can't Deploy App to HoloLens (DEP6957)

swebersweber
edited August 2016 in Questions And Answers

Hi,

I recently updated my HoloLens and Visual Studio and now and I can't deploy apps to the HoloLens anymore. Every time I try to deploy I get a DEP6957 error. I'm just using the HoloLens 101 Origami project as a test. My current setup is:

  • HoloLens: 14393.0.x86fre.rs1_release.160715-1616
  • Visual Studio: 14.0.25425.01 Update 3
  • Windows SDK: 10.0.14393.33 (I also have 10.1.10586.212 and 10.0.26624 installed)
  • Unity for HoloLens: 5.4.0f1-HTP
  • Developing on WIndows 8.1 Enterprise
  • Verified that my Windows 8.1 Developer License is up to date by running the Show-WindowsDeveloperLicenseRegistration PowerShell command
  • I can connect to the developer portal on the HoloLens without any problems
  • I have MaxVersionTested set to 10.0.14393.0 in my Package.appxmanifest
  • I've tried deploying over both WiFi and and USB and both fail in the same manner
  • I've tried resetting VS, HoloLens, and my PC
  • I tried unpairing all devices from the HoloLens and my VS isn't prompting me to enter a PIN when deploying so that seems odd
  • I've checked the "Uninstall and then re-install my package" check box in the project debug settings
Tagged:

Best Answer

Answers

  • Hi @sweber,
    We've had one other user report this issue. They also developing on a Windows 8.1 machine. If possible, I would suggest upgrading to Windows 10.

    https://forums.hololens.com/discussion/1848/first-time-deploying-an-app-but-cant-deploy-through-usb-or-remotely-dep6957#latest

  • Hi @ahillier,

    I did see that suggestion, I was just hoping to avoid doing that upgrade, but it seems like that would be the next best step. I just tried uninstalling the other two versions of the Windows SDK that I had installed (10.1.10586.212 and 10.0.26624) and I re-installed the most recent version (10.0.14393.33), but that didn't fix anything.

    I'll try upgrading to Windows 10 when I have some time and post the results here. If anyone else has some other suggestions in the meantime I'd be more than happy to try something else.

  • @sweber, that's great news!
    Thanks for letting us know :)

Sign In or Register to comment.