Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Handling Tracking Loss

I've been making an app that kind of relies on your to be in dark environments, however in the dark, the HoloLens loses its ability to perform spatial mapping. That's not such a big deal for my app but I'd like to be able to suppress the popup that says "trying to map your environment". I've been following this guide here:

https://developer.microsoft.com/en-us/windows/holographic/tracking_loss_in_unity

However, I am unable to follow it completely because the option to uncheck "Display Tracking Loss Image" is greyed out, as is most options in that part of the settings menu. Does anyone know how to enable those options?

Answers

  • I can't repro the state where that checkbox is disabled from a new empty project or a preexisting one. What build of Unity are you using? The latest is 5.4.0f3: http://unity3d.com/partners/windows/hololens

  • @Generalkidd,
    I have seen the behavior you describe when running Unity Personal Edition. When I use Unity Professional Edition, the option to change the image is available.

    I have not tried with Unity Plus, so do not know what the behavior is in that edition.

    Thanks!
    David

  • @timg said:
    I can't repro the state where that checkbox is disabled from a new empty project or a preexisting one. What build of Unity are you using? The latest is 5.4.0f3: http://unity3d.com/partners/windows/hololens

    I'm using Unity 5.4.0f1-HTP for now but I guess it doesn't matter if I upgrade the build or not.

    @DavidKlineMS said:
    @Generalkidd,
    I have seen the behavior you describe when running Unity Personal Edition. When I use Unity Professional Edition, the option to change the image is available.

    I have not tried with Unity Plus, so do not know what the behavior is in that edition.

    Thanks!
    David

    Does that also include the option to disable the check for spatial mapping which pauses your game and tries to map the surroundings?

  • Hi,
    I had run into the same frustrating problem, where I was unable to disable the "tracking loss" splash screen in a Unity application when using Unity Personal Edition.

    However, I was able to find a workaround that allowed me to suppress that splash screen despite tracking loss:

    Under \ProjectSettings\ProjectSettings.asset, find the line that says:

    m_HolographicPauseOnTrackingLoss: 1

    And change it to:

    m_HolographicPauseOnTrackingLoss: 0

Sign In or Register to comment.