Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Is there a way to choose which GPU Emulator runs on?

I'm currently on a Surface Book i7 w/ NVidia gpu.

When ever I try to start the Emulator - either through VS.Net Holographic project or Hyper-V, I get a kernel fault: TDR_VIDEO

The emulator then throws an error that says "Can't Start Emulator in resolution using desktop graphics card restarting using software graphics..."

What I did was go into device manager and disable the Intel HD 500 graphics card. This worked like a charm. So the question is - is there a way to select which card (gpu affinity) which the Emulator will use? Is there an option like this in Hyper-V? Or is this a bug?

Dwight Goins
CAO & Founder| Independent Architect | Trainer and Consultant | Sr. Enterprise Architect
MVP | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer
http://dgoins.wordpress.com

Tagged:

Best Answers

Answers

  • Sounds like a nVidia driver issue. I have an Dell i7 desktop with a Radeon (two 34" curved screen Dell monitors attached via hdmi and DVI-D) and the integrated intel graphics (with a 24" dell monitor via displayPort) and the emulator works like a charm.

  • probably, however if i choose nvidia and disable intel, it works. if i do the reverse it works, it's only when i have both video cards enabled does it yield the error.

    Dwight Goins
    CAO & Founder| Independent Architect | Trainer and Consultant | Sr. Enterprise Architect
    MVP | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer
    http://dgoins.wordpress.com

  • @Dwight_Goins_EE_MVP said:
    Choose the "C:\Program Files (x86)\Microsoft XDE\10.0.11082.0\XDE.exe" app and select you NVidia card. Whenever this app runs, NVidia GPU will be used exclusively for the app.

    When I selected the XDE from that path, it shows as "Windows Phone 7 Emulator (xde.exe)". However, it would not let me select the NVIDIA gpu, only the "Integrated Graphics" option is selected and the DropDownList is disabled.

    Did you take any further steps that enabled the NVIDIA option?

    PS - The emulator is listed when the project type is a C++ project but not when it's a C# project. I've even launched the emulator using the C++ project, kept it running and reopened C# project, didn't work :(

    Microsoft MVP - Windows Development
    More about me and my credentials

  • Actually you made me revisit this...
    You're right, when I had my Intel graphics disabled NVidia was selected and grayed out, but it appears once Intel is enabled, the integrated option is selected and grayed out. In any case it works for other types of apps (.exe) just not the XDE one. And overall it works for me, just not choosing the specific GPU I want for this specific app.

    As far as the C# project template issue, I would run the update 2 again. Make sure your C# language and features are all selected. There appears to be an invalid project template installed for c#.

    Dwight Goins
    CAO & Founder| Independent Architect | Trainer and Consultant | Sr. Enterprise Architect
    MVP | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer
    http://dgoins.wordpress.com

  • Hi everyone,

    Hyper-V Settings should allow you to choose which Physical GPUs to use in Physical GPUs tab. If you have multiple GPUs, you can enable/disable any of them by clicking the "Use this GPU with RemoteFX" check box.

Sign In or Register to comment.