Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Cannot use HoloLens Emulator

achilleachille
edited April 2016 in Questions And Answers

When I chose HoloLens Emulator instead of Local Machine in the target device tab, don't get nothing. Just like I haven't click, the text remain Local Machine altough I've clicked.
I've installed VS R2, Unity Beta for HoloLens and HoloLens Emulator and I've Hyper-V enabled. On the Microsoft tutorial 101, they click on HoloLens Emulator and they wait 10 second and the right text appear. How do I fix this problem?
[EDIT]It works if I use Local Machine as target device

Tagged:

Answers

  • I'm from Italy, sorry if I made any mistake in the text D:

  • On some systems the write up says it can take as long as 15 minutes to first start up. If you're not getting any errors, and you have successfully installed vs.net 2015, update 2, tools, and emulator, and you have at least windows 10 Pro and above edition, it should work.

    What are you computer specs?

    Dwight Goins
    CAO & Founder| Independent Architect | Trainer and Consultant | Sr. Enterprise Architect
    MVP | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer
    http://dgoins.wordpress.com

  • The problem isn't at the startup. I can't even chose the HoloLens Emulator from the list.
    My PC specs are:
    Windows 10
    8GB RAM
    500GB (60GB of free space)
    Intel i5 CPU
    Nvidia Geforce GTX 980 GPU

  • First try to create a C++ Holographic project, compile it and see if you can select HoloLens emu, if not, I would reinstall Update 2 and Tools.

    Dwight Goins
    CAO & Founder| Independent Architect | Trainer and Consultant | Sr. Enterprise Architect
    MVP | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer
    http://dgoins.wordpress.com

  • Ok I will reinstall them and I'll let you know

  • Do I have to reinstall Unity?

  • @achille said:
    Do I have to reinstall Unity?

    Unfortunately yes, I found that the list in Install the tools

    What looks very specific instruction sequence. I found even though VS 2015 said it was update 2. Control Panel. VS 2015 was declared as Update 1. So I uninstalled everything and started again by installing using the version on the install page.

    Remember to do custom VS2015 install and tick/check Tools 1.3 and the UWP Windows 10 SDK. This is then detected by Unity HoloLens 5.4.0b10-HTP (64-bit) on install.

  • Ok, Thank you

  • Internet in my countri is really slow so maybe it will be ready by tomorrow D:

  • Ok. I did reinstall everything (Internet helped me this time :smile: ) but it still doesn't work

  • Me too, I also have this problem. It looks like reinstall does not work. Is there any way to run the emulator standalone, outside of Visual Studio, so we can test?

  • achilleachille
    edited April 2016

    Does anyone hava a solution to this?

  • Why do you run it on Local Machine ? You should pick Emulator
    also be sure that you've turned on Hyper-V in "feature on/off settings" in your system

  • Sorry, you don't understand. I must run it on Local Machine (I don't want to, because I can't use any Hololens function). When I pick the Emulator from the target device list, it is like I haven't even clicked. It doesn't do nothing. Also, I have Hyper-V enabled and as DatVM said on StackOverflow (http://stackoverflow.com/questions/36434087/cannot-choose-hololens-emulator-as-debug-target-in-visual-studio) "in Hyper-V, cannot see any virtual machine in the list".

Sign In or Register to comment.