Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Redeploying Hololens apps

I have made a sample Hololens app using the Hololens Origami tutorial. I tried making changes to the scene, i.e, changed material, size etc, however those changes are not reflected in the deployed app when I view it in hololens. I tried cleaning the VS solution, restarting the hololens, uninstalling the app in hololens, restarting the computer, it keeps on showing the old version of the app. When I view the app using Unity play mode, I can see all the changes.

What am I missing here?

Answers

  • You need to rebuild your changes in Unity first and then build/deploy from Visual Studio.

  • HoloSheepHoloSheep mod
    edited October 2016

    @HciDevelopment

    Couple of things to think about when using a previous project as the starting place for a new project.

    Besides the obvious issues of caring baggage forward that you would avoid if you were to start a clean new project you also need to be careful with:

    • Unity Build
      Unity seems to save the output directory location from the original project. So, if you copy projectA to a new location projectA-copy and then go through the build process in unity, if you are not careful when building projectA-copy it will default out to the old App build directory under projectA. If you then go into the App directory under projectA-copy and launch the solution you would then be opening the old build that was copied from projectA and not the new one that you thought you just build for projectA-copy.

    If you do copy a project folder to use as a starting point, it is a good idea to kill the previously build folders and files

    • UWP App identity.
      You probably also want to rename the Assembly name to make the new app unique from the one you copied it from.

    One thing you can try is to remove the old app from your HoloLens and redeploy. That may remove an identity conflict. If you still end up with the old version deployed there is a good chance the when you are building in Unity you are saving the new build in a different location that you are expecting and the one you are deploying is an old build in a different folder created from the original project.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • edited October 2016

    Thanks for the suggestion. I created a new hololens app from scratch. The app just shows a sphere and it works well in the hololens too. Now, I changed the sphere to a cube and redeployed the app, it keeps on showing the old version that shows the sphere. This is how I redeployed:
    1. Built the project in unity and generated the output visual studio project in a new folder.
    2. opened the solution in visual studio.
    3. uninstalled the old app in hololens, and restarted it
    4. built and deployed the visual studio project through remote deploy option.
    5. the app is installed in the hololens but the same old one.

    I switched the platform and generated a exe file and saw that the cube can be seen in the new version. But when I change the platform to windows store, same problem occurs.
    What did I miss here?

  • @HciDevelopment

    Are you sure you are opening the Visual Studio solution that was created on the last Unity build?

    Are you seeing any errors when you deploy from Visual Studio?

    Something doesn't sound right.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • When I redeploy the project using USB cable it works fine, but when I redeploy using remote option, it doesn't work. I am not sure what the problem is, I have started using the Deploy to Device option instead of remote deployment.

Sign In or Register to comment.