Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Remoting & Simulation Not Working

edited December 2016 in Questions And Answers

I installed Unity 5.5.
Got Windows 10 Pro Anniversary.
I run the Remoting App on the HoloLens.

When attempting to remote:
'Connect' doesn't click in Unity. It's unclickable.

When trying simulation mode:
Failed to get HolographicSpace from SimulationManager




  • Options
    ahillierahillier mod
    edited November 2016

    I'm currently running a slightly older version of 5.5 (from 2-3 weeks ago) and am able to connect. Here are the steps that I take:
    1) Launch the Remoting app on HoloLens
    2) Open the 'Holographic Simulation and Remoting' window in Unity
    3) Change 'Perception Mode' to 'Remote to device'
    4) Enter the IPv4 address of my HoloLens into the 'Remote Machine Name' field
    5) Press 'Connect'

    I have had a few cases where connection failed and I had to reboot Unity and/or my HoloLens to get it working. I've also had issues where the HoloLens went to sleep and I had to reboot the Remoting app before I could connect again.

  • Options
    edited November 2016

    Thanks for your response.
    I rebooted the computer, the HoloLens.
    In Unity, I still cannot press the' Connect' button. It doesn't press. Can't click it.

  • Options

    Have you tried disabling the SharingService component in your app? I wonder if there might be some networking piece that is interfering with Unity's connection....

  • Options

    The app I'm creating is specifically using sharing. But I will give it a try.

  • Options

    Sharing has nothing to do with it.

  • Options

    Hello, if you're using Unity 5.5 Beta 10, you might want to revert back to Beta 9 to make the Holographic Simulator work properly. There's a bug in Unity 5.5 Beta 10 that prevents the loading of DLLs required for Holographic Simulator.

    I experienced the same issue that you have as well, but after reverting to Beta 9, Holographic Simulator works fine.

  • Options

    Awesome I will try thanks!

  • Options

    No, you don't have to revert back. Just click the field "remote device" so it is highlighted and then click connect. Also, make sure to open the holographic remoting application in hololens or it will not connect.

  • Options

    Edit: Type in the Ip address under remote machine, and then click the drop down to "remote to device". Then click connect.

Sign In or Register to comment.