Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

DEP6100 error with emulator

I get the following error when trying to deploy the sample Origami project to the emulator. I've tried un-installing and re-installing the emulator without effect.

I've seen others mention this error in the forums, but haven' t found a definitive answer -- has anyone been able to work through this?

_DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device 'F957827B-6FC8-4538-A5BA-3B3807152A56'.':
FileLoadException - Could not load file or assembly 'Microsoft.Tools.Connectivity, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)



  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited April 2016

    Check VS 2015 Community has Toolkit 1.3 , you my have to uninstall VS2015 and install the version from install page https://developer.microsoft.com/en-us/windows/holographic/install_the_tools
    Released 30th March 2016

  • Should have mentioned I'm running VS 2015 Professional, with Update 2 installed. The page at the link @Jimbohalo10 posted lists Tools(1.2)

    "If you choose a custom install, ensure that Tools (1.2) and Windows 10 SDK (10.0.10586) is enabled under Universal Windows App Development Tools node..."

    I see no updates listed for VS (checking Tools -> Extensions and Updates), is there a URL where I can update Tools/Toolkit to V1.3 ??

  • cvcolombcvcolomb
    edited April 2016

    So I don't think the Tools version is the problem. When I go to Settings and try to Modify my VS Pro 2015 installation it is already listing "Tools(1.3)" as installed.

  • Ran vs_community_ENU setup again to see what has been installed and everything is correct. The only slight difference is that in my original installation I got a message saying "Update 2" and in the new, working, installation "with Updates"

  • I had this problem as well on a machine that I was trying to run the emulator on. I tried uninstalling and reinstalling VS2015 with Update 2 and uninstalling VS2013, but I was never able to get past the same error.

    The only thing that cured my problem was reinstalling Windows 10, which was something I wanted to do anyways because the PC was updated from Windows 8.1. Reinstalling Windows to fix this is not a pretty fix, but it did do the trick in my case.

Sign In or Register to comment.