Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Unity Apps Only Appear In Windows

edited November 2016 in Questions And Answers

I've completed the official tutorial (Origami Collection) for the Hololens, and I'm now trying out my own first steps by just getting similar things working within a project of my own. Unfortunately, despite doing all the same things, I can't get the app to run the same way. Instead of viewing the 3D model and looking around it like I could in Origami, it's just a view of the project camera in a window.

Here's a picture of what I mean. Instead of a cube hologram floating in space that you can interact with, it's just a render of said cube in its window. I'm not sure what to do to fix this. Does anybody have any advice?

Best Answer

  • Answer ✓

    @Legionforce,
    In your player settings (Edit > Project Settings > Player), you will need to have Virtual Reality Supported checked and Windows Holographic selected.

    When you build your project, the UWP Build Type needs to be set to D3D.

    This should give you the results you are looking for.

    Thanks!
    David

Answers

  • Answer ✓

    @Legionforce,
    In your player settings (Edit > Project Settings > Player), you will need to have Virtual Reality Supported checked and Windows Holographic selected.

    When you build your project, the UWP Build Type needs to be set to D3D.

    This should give you the results you are looking for.

    Thanks!
    David

  • @DavidKlineMS said:
    @Legionforce,
    In your player settings (Edit > Project Settings > Player), you will need to have Virtual Reality Supported checked and Windows Holographic selected.

    When you build your project, the UWP Build Type needs to be set to D3D.

    This should give you the results you are looking for.

    Thanks!
    David

    David, thank you! My problem was that I forgot to check "Virtual Reality Supported". I really appreciate it.

Sign In or Register to comment.