Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Why is my app always deploying in 2D mode?

abiggsabiggs
edited April 2016 in Questions And Answers

I am currently writing an app for Hololens using the physical device. When I build my project from Unity, I select Universal 10 + D3D from the build options, and build the C# project. However, when I run the app and tap to place it, the resulting deployed app displays a 2D app window and never launches the application in 3D. I've deleted all the Unity temp files, including the generated project, and rebuilt it making sure to select D3D, but have had no luck.

Has anyone else encountered this issue?

Best Answers

  • jbienzjbienz
    Accepted Answer

    I made a different mistake than the ones above but ended up with the same outcome. I wanted to share the solution here since it isn't documented anywhere.

    When following the step-by-step directions for Holograms 101 I set the background to Black using the color picker instead of typing in the values. I ended up with R: 0, G: 0, B: 0, A: 10. Because there was a partial alpha, the app rendered in a 2D window instead of as a hologram, even though Virtual Reality Support was enabled.

    Hope that helps someone else.

Answers

  • @abiggs when you run the app are you seeing the Tap to place and run prompt?
    If you are not, and if you haven't already tried it you might want to do an air tap gesture.

    When an app deploys to the HoloLens (or emulator) it will appear as an app window. You then do the Tap gesture to place and run it.

    Similar to the Placement section in the HoloLens shell documentation: https://developer.microsoft.com/en-us/windows/holographic/hololens_shell_overview

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • Since I had already followed your lead and made a barebones sphere project myself when I saw your original post I then turned off the Virtual Reality Support in the project settings and now see what you mean about the 2D sphere in the 2D window.

    Good to hear you quickly found the problem and even better that you shared the lesson with the rest of us.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @abiggs I was looking for that ! Thanks !! :)

  • jbienzjbienz
    Accepted Answer

    I made a different mistake than the ones above but ended up with the same outcome. I wanted to share the solution here since it isn't documented anywhere.

    When following the step-by-step directions for Holograms 101 I set the background to Black using the color picker instead of typing in the values. I ended up with R: 0, G: 0, B: 0, A: 10. Because there was a partial alpha, the app rendered in a 2D window instead of as a hologram, even though Virtual Reality Support was enabled.

    Hope that helps someone else.

  • @jbienz said:
    I made a different mistake than the ones above but ended up with the same outcome. I wanted to share the solution here since it isn't documented anywhere.

    When following the step-by-step directions for Holograms 101 I set the background to Black using the color picker instead of typing in the values. I ended up with R: 0, G: 0, B: 0, A: 10. Because there was a partial alpha, the app rendered in a 2D window instead of as a hologram, even though Virtual Reality Support was enabled.

    Hope that helps someone else.

    Amazing, thank you. Was stuck so long.

  • @abiggs said:
    I am currently writing an app for Hololens using the physical device. When I build my project from Unity, I select Universal 10 + D3D from the build options, and build the C# project. However, when I run the app and tap to place it, the resulting deployed app displays a 2D app window and never launches the application in 3D. I've deleted all the Unity temp files, including the generated project, and rebuilt it making sure to select D3D, but have had no luck.

    Has anyone else encountered this issue?

    I encountered it too. I have checked the virtual reality settings and camera's rgba value, there is no problem.Also, the remote test on Hololens displays on 3D mode.
    But when I build the app into a vs project, and launch on the Hololens, it is 2D mode.
    Do you have any advice?
    Thanks a lot!

  • @HoloSheep said:
    Since I had already followed your lead and made a barebones sphere project myself when I saw your original post I then turned off the Virtual Reality Support in the project settings and now see what you mean about the 2D sphere in the 2D window.

    Good to hear you quickly found the problem and even better that you shared the lesson with the rest of us.

    I encountered it too. I have checked the virtual reality settings and camera's rgba value, there is no problem.Also, the remote test on Hololens displays on 3D mode.
    But when I build the app into a vs project, and launch on the Hololens, it is 2D mode.
    Do you have any advice?
    Thanks a lot!

  • @songs said:

    @HoloSheep said:
    Since I had already followed your lead and made a barebones sphere project myself when I saw your original post I then turned off the Virtual Reality Support in the project settings and now see what you mean about the 2D sphere in the 2D window.

    Good to hear you quickly found the problem and even better that you shared the lesson with the rest of us.

    I encountered it too. I have checked the virtual reality settings and camera's rgba value, there is no problem.Also, the remote test on Hololens displays on 3D mode.
    But when I build the app into a vs project, and launch on the Hololens, it is 2D mode.
    Do you have any advice?
    Thanks a lot!

    Having this issue as well. I manage to make a clean Unity project with just the MRTK examples in it that launches into 3D mode on the hololens, so there must be something causing this in my project. Currently comparing every setting to figure it out, but no luck so far.

Sign In or Register to comment.