Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

HA 210 ch. 6 Interactible.cs causing errors

HoloCanHoloCan
edited November 2016 in Questions And Answers

In 210 chapter 2, I completed the written instructions and the program loaded but failed to get past the fitbox intro image. When I clicked, VS stopped running the program and displayed an error with the Interactible.cs, particularly line 17 which is setting the default materials - "NullReferenceException was unhandled by user code".

Then watched the video which cuts out before the part where we add the interactible script to AstroMan. So I removed the script and it all worked. Parts still highlighted when the cursor moved over them but there was no audio difference. All went well till I got to ch 6 and I had to use the interactible script again, so I added it back in and copied it all from the source. Still, I got the same issue with the script.

"NullReferenceException was unhandled by user code"

I removed that line and got the same error just further down the script. It's probably an easy fix but I am new to coding. I should add, i'm using unity 5.4.

Tagged:

Comments

  • The same for me here...

  • I am not entirely sure how I resolved this issue. But since then I have been using 5.5 and an actual HoloLens. And I have done that tutorial a few times now and haven't come across this problem again.

    Although if you start the next tutorial, you will be using different scripts, so i'd suggest trying to do the other tutorials in the mean time. The holotoolkit is also totally different so you won't find that problem there.

    Maybe try re-downloading the gaze file and starting it over?

Sign In or Register to comment.