Unity 5.5 has released - please note Audio breaking change

The official download link for Unity has been updated to 5.5.0f3.

Please note the release notes regarding a breaking change when using the MS HRTF Spatializer.

"Audio: If previously using a Unity Hololens technical preview release with the Microsoft HRTF spatializer and the Audio Spatializer script component, said component now only controls room size properties. Distance-based attenuation is now set up in the AudioSource script component, so the Spatial Blend property needs to be set to 1.0 and the 3D Sound Settings need to be set appropriately."

If you update a project that was begun in Unity 5.4.0-HTP, you will need to set the 3D Sound Settings | Volume Rolloff Curve for each of your spatialized AudioSource objects to Logarithmic Rolloff to get the distance attenuation to match the previous behavior.

Thanks!

Tagged:

Comments

  • I see that Unity 5.5 has been released and it has HoloLens development ability. Is this the new path for all future Unity-HoloLens releases? Are the HoloLens technical preview going? I ask as I hate to upgrade have problems and downgrade. But, if this is the future then I will upgrade.

    Thanks in advance.

  • HoloLens support is now part of the mainline Unity builds, and this will be true going forward as well. The HoloLens technical preview will be retired, and future HL updates will be available as part of the mainline Unity releases.

  • @ChimeraScorn

    Besides the Audio breaking change is there a list of any other breaking changes that we should watch out for?

    I gather from @neerajwadhwa comments about the transition for the HoloToolkit that there are a number of fundamental changes that might break our projects when we switch over to using the main 5.5 branch of Unity.

    Perhaps the same question applies to our use of the HoloToolkit. Is there a list of things in our projects that we will need to fix and/or watch out for if we were using previous versions of the HTK and now switch over the latest version of the HTK in a project?

    Thanks!

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @HoloSheep yeah we did a phased breaking change for the HoloToolkit extensible Input Module.

    1. Please find the interface diagram and design discussion documented here.
    2. Master has all the Input module changes integrated now.
    3. We marked the older code with a release tag v1.5.4.0

    All the test scenes and prefabs have been updated in master and you can view them for reference.

    Next, I will update master to Unity 5.5 as documented in the HoloToolkit-Unity release plan.

  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited December 2016

    The install of Unity 5.5.0f3 went fine, but when I tried to work with Unity 5.5.0f3 there were problems. The root cause of this was, old beta versions namely 5.5.b8 and 5.5.b11, being installed.

    FIXED by uninstalling Unity 5.5.0f3 and ALL beta versions including other device versions of Unity leaving only the original 5.4.0F3 HTP (32 bit).

    Look in Control Panel -> Uninstall Programs -> Current installed Program List to check

    Reinstall by running the Unity 5.5.0f3 install loader again and everything works fine, even on Windows 10 Professional Insider Build 14971 :)

    I have downloaded Galaxy Explorer which has been updated to 5.5.0.F3 and it works well with the HoloToolkit-Unity release plan till end of year 2016 updates

    The Unity Editor Player also works with Galaxy Explorer.;.
    In the HoloLens Emulator the app responds to a wired Xbox 360 controller using buttons and the left and right stick to control zoom and movement.

    In general everything works better.
    Thanks B) o:)

  • I'm confused. I downloaded 5.50f3 and i'm trying to create a new project (I'm showing this in a few days, my demo worked fine in earlier builds). Does 5.5 not come with the Windows Store built-in? And I don't see how it has "Hololens support built-in". Do I need to install anythign other than the toolkit into the project and 5.5 onto my machine (e.g. are there other add-ins to Unity that need to be installed? Maybe a quick post that walks through the 5.5 workflow that I'm missing?

  • When installing there is a checkbox for windows sdks. But if you didn't grab it then go to build settings and select Windows Store and there will be a button to download the sdk. Once you have the SDK there is a drop down for target device. Set that to Hololens.

    Taqtile

Sign In or Register to comment.