Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Error when uploading SharedHologram Tutorial 240 (Completed)

edited December 2016 in Questions And Answers


When uploading Shared Hologram 240 Tutorial Completed project in a console pop up eror:
System.Exception: Package directory not found: "C:.......\System.Private.DataContractSerialization\4.1.0". at UnityEditor.Scripting.Compilers.NuGetPackageResolver.Resolve () <0x2b19638 + 0x0032b> in :0
at AssemblyUpdater.Core.AssemblyUpdaterContext.AddFrameworkFolderToSearchPath (Mono.Cecil.AssemblyDefinition assemblyDefinition, Mono.Cecil.DefaultAssemblyResolver resolver, IAPIUpdaterListener listener) <0x2b11a40 + 0x00263> in :0
at AssemblyUpdater.Core.AssemblyUpdaterContext.ReadAssembly (System.String assemblyPath, IAPIUpdaterListener listener, FileAccess mode, System.String[] searchPaths) <0x2b0f4b0 + 0x00163> in :0
at AssemblyUpdater.Core.AssemblyUpdaterContext.From (System.String assemblyPath, IConfigurationProvider configuration, System.String[] assemblySearchPaths, UpdaterMode mode, IAPIUpdaterListener listener) <0x2b0f3c8 + 0x00073> in :0
at AssemblyUpdater.Core.AssemblyUpdaterContext.From (System.String assemblyPath, System.String[] assemblySearchPaths, UpdaterMode mode, IAPIUpdaterListener listener) <0x2b0f388 + 0x0002f> in :0
at AssemblyUpdater.Application.Program.CheckForObsoleteAPIUsage (AssemblyUpdater.Application.CommandLineSpec config) <0x2af0b58 + 0x00043> in :0
at AssemblyUpdater.Application.Program.Main (System.String[] args) <0x2a90f18 + 0x000fb> in :0
UnityEditor.Scripting.APIUpdaterHelper:DoesAssemblyRequireUpgrade(String)

P.S Unity 5.5.0f3

Answers

  • Hi @stannis995,
    I am able to build/deploy this project without any issue. Can you expound on what you mean by 'uploading'? Are you exporting the assets folder or trying to save the project to the cloud? I'll need some steps to follow in order to try a repro.

    Have you tried to 'upload' any other Academy courses? Did you get the same error?

    From the error, it looks like you might be missing an assembly in Unity. When you installed Unity 5.5, did you also install the 'Windows Store .NET Scripting Backend' and 'Microsoft Visual Studio Tools for Unity' components?

  • edited December 2016

    Hi @ahillier
    I got this error then I had uploaded this tutorial project. All assembles was installed before. But this error was resolved by installing 5.6 Unity version. But then I got another error with StandartFast.shader something about not supporting some of shaders. I can't reproduce it now. But after deleting this file I acctually managed to make a bild. But then starting this app on Hololens my Polys avatars was represented witout detalization. Just 1 glowing mono texture. Obviously this (StandartFast.shader) do something with detalization but it frequantly causing errors.
    P.S. Sorry for my bad english.

Sign In or Register to comment.