Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Couldn't change the Processor of the virtual machine

Hi -

I'm running Windows 10 on Parallels Desktop 11 on a i5 Macbook Pro with 8gigs of RAM- I have 2 processors and 4gigs of RAM allocated to the Windows VM. Nested Virtualization is turned on in Parallels. Hyper-V is enabled in Windows.

I am able to install VS 2015 Community, with UWP 1.3, and the Hololens emulator. When I actually attempt to run a project, the emulator opens, creates a VM in Hyper-V, but pops up an error. The odd thing about the error is that it says that the number of processors is out of bounds a and should be 1 or 2, but when I look at the Hyper-V VM configuration, the number of processors is "2". A screen capture of the error is attached.

Any help would be appreciated.

Tagged:

Answers

  • @dsea I have not seen this error but perhaps you could try to delete the HoloLens Emulator VM in Hyper-V manager and launch the emulator again to see if it helps.

  • dseadsea
    edited April 2016
    Thanks @neerajwadhwa

    When I launch the Hololens emulator in Visual Studio the Hyper-V Emulator creates a VM, the error pops up, but when I close the Hololens emulator in VS, the Hyper-VM Emulator disappears. Is it supposed to persist even when the HoloLens emulator is closed? Perhaps that's a clue?
  • Can you create and start a VM in hyper-v manager?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Patrick no, I didn't do so in advance, running the Holographic project in VS appears to create (temporarily) a new VM in Hyper-V, which disappears when I shut down VS. If I do create a VM in Hyper-V, how do I tell VS to use it to run the Hololens Emulator? Thanks.
  • I'm curious if Hyper-V is working on your PC.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Patrick this is the first time I've played around with Hyper-V, so hard for me to tell. Are there any specifics I should look at?
  • In the hyper-v manager, you can select your machine name on the left, right click on it, and select 'new->Virtual machine'. You can click next through the new VM wizard, although on the memory screen you may want to switch the memory to 2048. When you are done with the wizard you can right click on your new VM and select 'start'.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Patrick I created a VM in Hyper-V and it cannot start. I'm getting a "Not enough memory to start the virtual machine" error. Which seems a little odd. I'm allocating 4GB to the Windows VM on Parallels and 2gb to the Hyper-V VM with dynamic memory. Not sure why it won't work.
  • @Patrick I changed the Hyper-V VM setting to 1gig of RAM, and now it works. I'm reinstalling visual studio, so can't test the Hololens emulator right now. How would I tell the emulator to use a specific hyper-v VM?
  • Did you enable nested virtualization? Everything I've seen on the web about running the emulator in parallels requires you to change the number of processors in your VM to 1. Here's a link to their KB article.

    Given this, I suspect that the HoloLens emulator will not work in Parallels. The HoloLens is a multi processor device and even if you change the number of processors on your emulator, when Visual Studio launches the HoloLens emulator again it will set the processor count back. If you can get this to work, please let us know how. I don't have a system with Parallels to experiment with.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Patrick Yup, I have nested parallelization turned on

    I created a VM in Hyper-V with the name that Visual Studio was expecting, and set the RAM to 1gb and the processors to 1. Then I confirmed that this VM could start, which it did. I started up the HoloLens emulator again, and this time I got this error:

    "the emulator was not able to set the VHD for the SD card on the virtual machine. Object reference not set to a reference"
  • PatrickPatrick mod
    edited April 2016

    You'll need to fix the paths below for your system:

    IDE controller 0 should have:

    C:\Users\youracct\AppData\Local\Microsoft\XDE\10.0.11082.1039\dd.1268x720.2048.vhd

    and IDE controller 1 should have:

    C:\Users\youracct\AppData\Local\Microsoft\XDE\10.0.11082.1039\dd.1268x720.2048.sdcard.vhd

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @desa Did you get this running in parallels?

  • @Starchland

    No, I wasn't able to. I followed the suggestions provided here and I was getting an "Emulator could not set memory..." Error.

    If anyone does have any further info, it would be much appreciated.
  • edited May 2016

    Hey @dsea - I was able to get this working, by setting the following in the "CPU & Memory" tab of the "Hardware" settings for the VM:

    1) number of Processors to 4
    2) the Memory to 8192 MB
    3) Check "Enable nested virtualization" under "Advanced Settings".

    I didn't have to muck with any of the Hyper-V settings directly.

  • how is performance?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • So far, I've just create a Hello World to get it running, so I can't comment on the performance. Also, I won't receive my device until Wednesday, so I don't have a device to compare.

  • Thanks @patrickoshaughnessey, I think part of the problem might be that I only have 8MB of RAM total on my computer. I'm guessing that might not be enough to run OS X, Windows, and the Emulator all at the same time. How much RAM do you have on your machine?

  • @dsea I have a MacBook Pro (Retina, 15-inch, Late 2013) with 16Gb of RAM. It still does chug at times when running Windows 10 + Visual Studio + Unity + Emulator, but is still within acceptable limits.

Sign In or Register to comment.