Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Assembly-CSharp-firstpass.dll missing from Origami

That's the problem. I got through the tutorial, and it gets stuck with hundreds of errors that boil down to Metadata file "\directory\Origami\UWP\Assembly-CSharp-firstpass.dll" could not be found

when I get to Visual Studio.

I downloaded from the links on the Hololens 101 tutorial page, on Friday last week.

Is there a quick anything I should look for? SerializationWeaver gives an error code 1 when I try to rebuild the firstpass dll on its down.

Best Answer

Answers

  • Make sure that your Unity build settings are setup properly.

    When you open the visual studio solution, make sure that you switch the build target to release/x86 (by default the solution will load in debug/arm).

    In Visual Studio Update 1 there were 10k+ errors that came from Intellisense. Those errors would go away if you compiled and then reloaded the solution.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • Thanks for the response, Patrick.

    I Followed the tutorial steps at least 10 times. Wiped and started with fresh copies of the project each time. Project Setup left as it was for the project (Hololens vr device is showing.)

    Did the release/x86 and CTRL-F5 to launch it (When the errors disappear and it just shows two lines of the missing firstpass).

    I'm trying to figure out if I'm missed installation of something simple. VS 2015 Community Update 2 with the nodes selected as per tutorial (Tools 1.3.1 and UWP 10 I think) the latest unity HTP build (14 at least was considered new on Friday).

    Emulator is installed, even though I don't expect to use it.

    Hololens is in Dev mode with updates checked.

    Is there potentially another part of VS that I may not have installed?

  • Is it supposed to be D3D instead of XAML in the build settings?

  • @RealityControls,
    When making a 3D holographic experience, use the D3D option. Your Unity build settings should look like this (except for 'Scenes In Build', which should contain 'Origami' instead):

  • HoloSheepHoloSheep mod
    edited April 2016

    Sorry @RealityControls is correct, this is a separate question deserving a separate thread. Please disregard this post and see the new thread.

    @ahillier so besides being able to invoke the system keyboard, in what other scenarios would it be appropriate to set the "UWP Build Type" setting in Unity to XAML?

    There was a post in another thread asking if we could, and if so how to manually make the programmatic switch in our apps between the 3D Volumetric mode and the 2D Xaml mode from within Unity, but I was unable so far to find any more information on either that specifically or on the details on when to use a UWP Build Type of D3D vs XAML and the benefits of each.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • @ahillier Yep, that's exactly how mine's setup.

  • @HoloSheep pssst, that's call thread highjacking ;) On Reddit you'd be flayed repeatedly.

  • @RealityControls,
    When you downloaded the project, it should have come with a 'Catch up Chapters' folder. You could try loading and building one of the later chapters to help rule out any errors on the code/project side of things. You will still need to set all of the build settings in Unity and VS.

    Did you happen to install the latest version of Unity (beta 14)? Some people forget to do the second step for installing the UWP Runtime, which can lead to a host of errors. Also, double-check that you have Update 2 installed for Visual Studio and ensure that 'Tools (1.3.1) and Windows 10 SDK (10.0.10586)' is enabled.

    Thanks,
    ~Angela

  • edited April 2016

    @hillier

    Thanks for checking. I've gone through the installations again, and checked the packages with VS com 2015 update 2. The Assembly-CHarp-firstpass is choking at

    (line 175 of the .csproj file)

    <Exec Command="&quot;$(UnityWSAToolsDir)\SerializationWeaver\SerializationWeaver.exe&quot; &quot;$(TargetDir)Unprocessed\$(TargetFileName)&quot; -pdb -verbose -unity-engine=&quot;$(SolutionDir)$(SolutionName)\Unprocessed\UnityEngine.dll&quot; -unity-networking=$(SolutionDir)$(SolutionName)\Unprocessed\UnityEngine.Networking.dll &quot;$([System.IO.Path]::GetFullPath('$(IntermediateOutputPath)').TrimEnd('\'))&quot;" />

    with an error code 1.

    Everything beyond this is, I assume, a result of the inability to build firstpass.

  • :) Wow. That's a new one to file in the solution bank. Thanks for sharing your solution!

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • I think it's more about spaces in your path or file names than the length.

  • Thanks for the solution @RealityControls . It works for me after moving the visual studio solution folder to the root of drive.

  • I had the same error, I needed to update my NuGet packages for the solution. Once I did, it built correctly.

  • edited September 2016

    Solution (that worked for me)
    I hade the same error and I needed to enable my NuGet.
    Go in Tools -> Options -> NuGet Package Manager -> Automatically check for missing packages during build in Visual Studio. This solved my problems with dlls.

  • Check this web site, It explains what have to be change in the Nuget configuration

    http://www.imaginativeuniversal.com/blog/2017/06/24/hololens-fix-visual-studio-2017-build-error/

  • In Unity go to Edit>Project Settings>Player
    In Other Settings switch API Compatibility Level from .NET 2.0 Subset to .NET 2.0

Sign In or Register to comment.