No colors in 3D viewer?

When I open my FBX model with the 3D viewer all color information is lost. The result is a solid white model, and it is hard to see any detail at all. If I open my FBX model in FBX Review on my laptop it looks correct.

There is a warning in the pop-up screen, "Multiple materials assigned to a single mesh". I tried textures, solid colors, nothing seems to work.

Any suggestions?

Best Answer

Answers

  • Jarrod1937Jarrod1937 ✭✭✭
    I'd imagine their model reader can't handle a single mesh with multiple material assignments (I assume different parts have different assignments). So it probably just drops all materials assigned to it, hence the white. This kind of comes down to their model support that is programmed into the viewer app.
  • That may be so, but is there ANY way to load a colored model?
    I've tried various FBX files that display fine in other apps, no luck.

  • Moved to Microsoft Published Experiences section as this is a question about the 3D Player beta application.

  • Does anyone have any thoughts on this?

  • Usually when this happens you have to reassign the materials in unity manually. The downside with this is, if Unity broke up your model, it might not map the UV coordinates properly, if this is the case you need to break your model up manually before importing. Im not a 3d artist so I do not know the ins and outs of what you have to watch out for, or limitations you need to keep in mind, but I'm sure there is documentation on Unity's site, or someone has created a blog post with tips and tricks ;)

  • Im not writing a Unity App, I'm simply loading an FBX model from OneDrive using the 3D viewer application.

  • @javanator - Any chance you want to share the FBX file with us, so we could take a look?

  • We're in the same boat @javanator <<? Any luck on finding the solution to this ?

  • If you are using Revit you can export the model to an Navisworks NWC file and then export the FBX from there. You'll have to assign colors in Revit using the Materials tool. Any modifications in Navisworks do not get updated in the FBX export.

  • In the same boat here, no colors for me either. Will see what I can find.

  • CesarGarCesarGar admin
    edited September 2016

    It'd be great if you could share out some of the specific models you're seeing this so we can take a look at the issue.

    I'm a Microsoft employee and a member of the HoloLens team, however I do not always speak on behalf of Microsoft.

  • I'm having the same problem. My model was exported from SketchUp Pro as an FBX file. In SketchUp the model has a graphic texture applied to a simulated fabric. Once that FBX file is loaded in 3D Viewer Beta the fabric just becomes white but so does a much more simple face. I'm happy to share and example model with the dev team. Just DM me.

  • @jemiaha said:
    I'm having the same problem. My model was exported from SketchUp Pro as an FBX file. In SketchUp the model has a graphic texture applied to a simulated fabric. Once that FBX file is loaded in 3D Viewer Beta the fabric just becomes white but so does a much more simple face. I'm happy to share and example model with the dev team. Just DM me.

    I'll contact you.

    I'm a Microsoft employee and a member of the HoloLens team, however I do not always speak on behalf of Microsoft.

  • I have a solution to this problem. First import your model into blender. In the render panel, scroll down to 'bake'. Change 'bake mode' to textures, and check 'bake to vertex color'. Then click 'Bake'. The model should now have per vertex coloring. Export the FBX file and import into 3D viewer, it should work!

  • I was suffering from the same problem until a while but I solved it.
    In my case, embedding texture in FBX file solved the problem.
    FBX Converter (http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=22694909) solved the problem. Once you have installed the software, it will start up. When starting up please drag & drop the FBX file you wrote in Blender into the window on the left side of the screen. Next, please check "Embed media" in the lower right and press "Convert" button.
    ((Although it is a Japanese site, I referred to the following site.
    http://nn-hokuson.hatenablog.com/entry/2016/06/29/220310))
    I hope your problem will be resolved.

  • Hello everyone,

    HoloLive is your solution.

    We have launched Revit and Navisworks plugins for HoloLens 3 months ago. It is very simple to take your large BIM models from Navisworks to HoloLens with all material and textures as simple as one click. You need to install HoloLive app on HoloLens. It is cloud based solution and you can also sync your models to HoloLens also.

    For more information: www. VisuaLive3D.com

    You can start with 7 days trial.

    VisuaLive3D Team

  • edited September 2017

    Hi all, picking up on this, i have exported multiple 3d scans from rhino to fbx, the model loads in but no texture. the details reference 2 textures. Is there a work flow. the original file is vrml?

  • Do you have access to 3DS Max? There seems to be multiple ways to attach materials to geometry within FBX - and 3DS Max seems to be the one that does it in a way 3D Viewer can read.

  • I had the same problem with Revit because apparently it can't handle a single mesh with multiple material assignments. However if you assign material, colour in Maya or 3D max you can see them in Hololens. Make sure in the exporting process go to media option and thick embedded media option.

  • It could also be because Autodesk materials don't work well with Unity. You may have to convert them. There's an online tool available that does it for you - http://materialconverter.com

Sign In or Register to comment.