Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Emulator shows Skybox instead of Origami scene

schubboyschubboy
edited May 2016 in Questions And Answers

I have successful deployment to the Emulator, I see my app in the OS, and I get Visual Studio to deploy it just fine. But, with my Main Camera setup with a Black clear color, the emulator just shows the default horizon/skybox, and none of the tutorial's origami scene: meshes/lights/etc do not show at all. I am following the 101 video & instructions from the hololens tutorial site. Can anyone suggest what I may be doing wrong here?

Tagged:

Best Answers

Answers

  • Did you add the origami scene in the Unity build settings window?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • @Patrick said:
    Did you add the origami scene in the Unity build settings window?

    Yes, I named both the scene and the project "Origami" as the tutorial specifies, added it to the build settings, and it shows up in the "Scenes to Build" window, with a check in the checkbox.

  • Could you take a screen shot of your camera settings and your unity build settings?

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • Jarrod1937Jarrod1937 ✭✭✭
    edited May 2016

    In general you shouldn't see a skybox at all even in Unity. If you do, then you have a camera controller somewhere that is set to skybox instead of clearing to black. Since you said you already have this done, make sure you also don't have any other camera in the scene as well.

  • @schubboy said:

    @Patrick said:
    okay, well that all looks right (except for the random cubes. :))
    Maybe something is corrupted in the Unity build output. Try this:
    1. Close unity and visual studio
    2. Go to where your origami project is
    3. Delete everything except for ASSETS and PROJECTSETTINGS
    4. Start unity back up and rebuild

    After step 2 your origami folder should look like this:

    Sorry, the random cubes were my attempt to make sure no matter when I looked, I had something to see. I am nuking and starting over now, we'll see where that leads.

    To sum up the solution - I nuked the project and started over, and now everything works perfectly. Just another day in the life...

Sign In or Register to comment.