Packaging and Sideload

ntndeyxntndeyx
edited May 2016 in Questions And Answers

Hi,

I have tried to package the Origami project in the tutorial Holograms 101e and sideload the app from Windows Device Portal but failed...

I followed the steps described on this page: Packaging Universal Windows apps for Windows 10.

After building the Origami project in Unity, there are 3 projects in solution "Origami" when opened in Visual Studio. Only the "Origami(Universal Windows)" one has the "Store" option, so I clicked on it.

In the "Create an App package" section, for step 3, I chose "No", since I'm not going to publish the app to the Windows Store.

And in the same section, step 6, I unchecked x64 and ARM because if they are checked, when creating the package it will ask for these files: Origami\App\Origami\Plugins\x64\AudioPluginMsHRTF.dll and Origami\App\Origami\Plugins\ARM\AudioPluginMsHRTF.dll, while I only have Origami\App\Origami\Plugins\X86 directory(after build the project in Unity).

Then I clicked "create", it generated a file called: Origami_1.0.3.0_x86.appxsym.

After the package was generated, I tried to install it in the Windows Device Portal, it gave this error:

Failure reason: Failed to start deployment. Failure text: Package could not be opened. (0x80073cf0)

Did I miss anything? What is the correct way to package an application for HoloLens?

Thanks!

Best Answers

  • ahillierahillier mod
    Accepted Answer

    @ntndeyx,
    Another thing to check is that the app does not already exist on your HoloLens. On the Windows Developer Portal Apps page, expand the drop-down list at the top and look for Origami. If it's in the list, then select it and press the 'Remove' button to delete the old app from your device. You can then try to re-install your app using the app package.

  • Accepted Answer

    @ntndeyx ,
    In your AppPackages\Origami folder there should be a Dependencies\x86 folder. Please try adding each .appx file in this location to the Dependencies area in the Windows Device Portal > App manager page when you install your bundle.

    From the latest message, it appears that one or more required packages could not be found or were the wrong version.

    Thanks!
    David

Answers

  • @ntndeyx ,
    The .appxsym file contains your application's symbol files, not the application itself. When you packaged the Origami project for the Windows Store, Visual Studio will have created an appxbundle (ex: Origami_1.0.3.0.appxbundle) or an appx file (ex: Origami_1.0.3.0_x86.appx), depending on whether or not you requested a bundle to be created.

    This is the file you use when installing your application using the Windows Device Portal.

    Thanks!
    David

  • ntndeyxntndeyx
    edited May 2016

    @DavidKlineMS
    Sorry, I was looking at the wrong folder... there is only Origami_1.0.3.0.appxbundle file in the previous package folder because it was not able to find the file Origami\App\Origami\Plugins\x64\AudioPluginMsHRTF.dll .
    After unchecking x64 and ARM I did get an .appxbundle file generated in the new package folder 1.0.4.0.

    Now I get this error after click on the "Install" button in the Windows Device Portal:

    Failure reason: Failed to start deployment. Failure text: Install failed. Please contact your software vendor. (0x80073cf9)

    I'm not sure if this has anything to do with the certificates. But I didn't find where to install certificate. There is no "Use developer features" option(which was mentioned in the instruction: Sideload LOB apps in Win10) in Settings -> Update & Security > For developers menu of HoloLens.

    Thanks,
    Yue

  • @ntndeyx ,
    Are you using the Windows Device Portal to deploy to the emulator or a HoloLens? The emulator is configured to always be in developer mode.

    If you are deploying to a HoloLens, you will need to turn this option as well as enable the Windows Device Portal setting.

    This article talks about using the Windows Device Portal with HoloLens.

    Thanks!
    David

  • ahillierahillier mod
    edited May 2016

    @ntndeyx,
    The Windows Device Portal page for HoloLens explains how to set this up.

    Here's an overview:
    You need to enable developer mode on the device itself. In HoloLens, select the 'Settings' app from the menu and place the tile to launch. Then:
    1) Select 'Update & Security' option on the bottom right
    2) Select 'For developers' option on the left
    3) Toggle 'Developer Mode' to 'On'
    4) Scroll to bottom of page and toggle 'Device Portal' to 'On'

    To access the Windows Developer Portal for HoloLens, go to http://yourHoloLensIPAddress and select 'continue to this webpage'. You might need to set-up/enter a username and password for the device. Once loaded, select the 'Apps' link on the left. The 'Apps' page is where you can sideload your app. In the 'Install app' section, click the 'Browse' button and navigate to the AppPackages folder created for your project (you'll probably find it under the App\Origami folder). You should have an .appxbundle there that you can select. Then press the 'Go' button under 'Deploy' and wait for the 'Done!' message to appear.

    After the application has been installed on your HoloLens, you will be able to find it in the 'All Apps' section (select the '+' symbol) on your device and then you can place it's tile to launch your application.

    I hope this helps. Please let us know if you continue to encounter errors.
    ~Angela

  • ntndeyxntndeyx
    edited May 2016

    @DavidKlineMS ,

    I have the Device Portal option turned on already. I am trying to use the Windows Device Portal to deploy to an actual HoloLens device.

    I have already read the article you linked above.

    When I click on "Go" to deploy, I got the (0x80073cf9) error that mentioned in my previous comment.

    Do I need to install any certificate( which was mentioned in the sideload instruction) to make this work?

    When I create the package I unchecked x64 and ARM, do they matter? If they do, how can I solve the file not found issue that occurs in the package creation step? (Origami\Plugins\x64\AudioPluginMsHRTF.dll and Origami\Plugins\ARM\AudioPluginMsHRTF.dll which I mentioned in the first post)

    Thanks,
    Yue

  • The arm and x64 packages are not needed.

    Can you try restarting the HoloLens device (and perhaps the PC)?

    Thanks!
    David

  • @ntndeyx,
    You might also need to enable developer mode on your development PC, if you have not already done so. Go to 'Settings > Update & Security > For developers' and select the 'Developer mode' option.

  • ahillierahillier mod
    Accepted Answer

    @ntndeyx,
    Another thing to check is that the app does not already exist on your HoloLens. On the Windows Developer Portal Apps page, expand the drop-down list at the top and look for Origami. If it's in the list, then select it and press the 'Remove' button to delete the old app from your device. You can then try to re-install your app using the app package.

  • ntndeyxntndeyx
    edited May 2016

    @DavidKlineMS , I restarted HoloLens and PC, and removed the Origami app that was already in the Apps list as @ahillier suggested (also tried to restart HoloLens after the remove). I double checked, the PC is in developer mode.

    It still fails but with a different error message... :

    Failure reason: Failed to start deployment. Failure text: Package failed updates, dependency or conflict validation. (0x80073cf3)

  • Accepted Answer

    @ntndeyx ,
    In your AppPackages\Origami folder there should be a Dependencies\x86 folder. Please try adding each .appx file in this location to the Dependencies area in the Windows Device Portal > App manager page when you install your bundle.

    From the latest message, it appears that one or more required packages could not be found or were the wrong version.

    Thanks!
    David

  • @DavidKlineMS Thanks a lot! That fixed it.

    Yue

  • Hi Everyone,
    I have appxbundle and tried to install using app manager on browser on Holonlens DE.. it gives an error
     DeployFailure reason: Failed to start deployment. Failure text: Package failed updates, dependency or conflict validation. (0x80073cf3)
    Then I have added .appx file on dependency section then it gives an error as
     DeployFailure reason: Failed to start deployment. Failure text: Install failed. Please contact your software vendor. (0x80073cf9)
    Can anyone help me to resolve this issue..
    thanks
    Sham

  • I got error when I install app to hololens , can anyone know how to fix it?

    Installation Failed:Failure reason: Windows cannot install package DigitalAssistant_2.3.5.0_x86__2mf2khke34412 because this package depends on a framework that could not be found. Provide the framework "Microsoft.NET.CoreRuntime.1.1" published by "CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x86 processor architecture and minimum version 1.1.26702.0, along with this package to install. The frameworks with name "Microsoft.NET.CoreRuntime.1.1" currently installed are: {Microsoft.NET.CoreRuntime.1.1_1.1.25915.0_x86__8wekyb3d8bbwe} Failure text: Package failed updates, dependency or conflict validation. (0x80073cf3)

Sign In or Register to comment.