Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Unity Poor Perfomance on Demo Scenes

Hello,

I'm pretty new to HoloLens development and I'm facing some basic issues with Unity3D. (V.5.6.1f1)
I started off by following the provided guides by Microsoft on how to create and deploy unity scenes for the HoloLens. I'm currently working on the Holograms 210 Gaze demo project and I'm fighting with a very poor rendering perfomance. I tried to match all the settings they do in their videos, but I'm not getting above 10 - 20fps which is horrible.

Can anyone guide me a bit so I get a perfomance around the 60fps goal? Are there some special settings I have to be careful with? My render settings are on fastest and the rendering is set to 16-bit depth. The app I want to build after this will have around 30-40k tris and does not need reflections or shadows (unlit shader). Thanks for any help!

Best Answers

  • binloanbinloan
    Accepted Answer

    @trzy said:
    Debug/Release is set in Visual Studio. You should see it up top.

    Also, make sure your Quality settings in Unity are set to Fastest. If you are unsure, go to Edit -> Project Settings -> Quality and then post a screenshot here.

    The release settings helped a lot and made at least 10fps more. Also my .fbx
    consisted out of many sub-objects. This created a huge draw call number in Unity which then caused my lag. By melting as much parts as possible I reduced my draw calls from around 80 to 15. At that moment everything went buttery smooth. Thanks for all your suggestions.

Answers

  • trzytrzy ✭✭✭

    Out of curiosity is HDR enabled on the Main Camera? If so, disable it.

  • @cre8ivepark said:
    @binloan Are you using Master or Release for the build? Typically Debug build is quite slow.

    Where do you set this? Inside Unity or after the build inside Visual Studio?

    @trzy said:
    Out of curiosity is HDR enabled on the Main Camera? If so, disable it.

    I have to check that, but as I used the demo scene for testing I "hope" they had set it up properly... I will report back.

  • @trzy said:
    Out of curiosity is HDR enabled on the Main Camera? If so, disable it.

    So I checked back, HDR is disabled on the camera. Any other suggestions? I'm running the GameControllerManipulatorTest scene from the holotoolkit and on my pc it has a rendering time of around 1.2ms with 2 batches and 292 tris. Same problem on the hololens...

  • trzytrzy ✭✭✭
    Debug/Release is set in Visual Studio. You should see it up top.

    Also, make sure your Quality settings in Unity are set to Fastest. If you are unsure, go to Edit -> Project Settings -> Quality and then post a screenshot here.
  • binloanbinloan
    Accepted Answer

    @trzy said:
    Debug/Release is set in Visual Studio. You should see it up top.

    Also, make sure your Quality settings in Unity are set to Fastest. If you are unsure, go to Edit -> Project Settings -> Quality and then post a screenshot here.

    The release settings helped a lot and made at least 10fps more. Also my .fbx
    consisted out of many sub-objects. This created a huge draw call number in Unity which then caused my lag. By melting as much parts as possible I reduced my draw calls from around 80 to 15. At that moment everything went buttery smooth. Thanks for all your suggestions.

Sign In or Register to comment.