Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Locatable camera problems while capturing black holograms?

Hey,

I have the locatable camera mixed reality capture working within my app by following this tutorial https://docs.unity3d.com/Manual/windowsholographic-videocapture.html.

I have set hologram capture to true and hologramOpacity to 1.0f. However the issue arises with holograms that should ideally clear to black. They are appearing as solid black in my final video capture. I need the black to be transparent so that I create a dark box of sorts. While it clears correctly while I am viewing it in the hololens I need it to also clear in the final mixed reality capture. Is there any workaround for this or parameter I can set?

Answers

  • trzytrzy ✭✭✭

    Black is the new black, man.

    There's nothing magical about the color black on HoloLens. It renders as black in the frame buffer, which is what you are seeing in the mixed reality capture. Now, the HoloLens's physical display works by projecting light that then reflects back into your eye. There's no such thing as black light, so the value 0 ends up displaying nothing.

    If you want it to be transparent, use a shader/material that supports transparency and set the alpha channel of the transparent region to 0 (full transparency).

Sign In or Register to comment.