Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

How to fix Capability 'internetClientServer error

evanjamesevanjames
edited May 2016 in Questions And Answers

How to correct the error below ?

error message
"How to fix Capability 'internetClientServer' is required, please enable it in Package.appxmanifest"

Tagged:

Best Answers

  • HoloSheepHoloSheep mod
    Accepted Answer

    @evanjames in Unity, from the menu go to:
    Edit > Project Settings > Player
    In the Inspector window from the tab with the Windows Store icon:
    Expand the Publishing Settings section and scroll to the bottom area where you see the Capabilities list and look for:

    • InternetClientServer
      make sure that option is checked...

    Then rebuild from the Build Settings window and then deploy from the Visual Studio Solution.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • HoloSheepHoloSheep mod
    Accepted Answer

    @Jesse_McCulloch said:
    it never updates the package.manifest even if you make changes that should update it in the unity side.

    @evanjames if as @Jesse_McCulloch says is true and some bug is preventing the setting from being updated, one easy work around would be to delete the Unity generated App and UWP folders:

    and rebuild from Unity's Build Settings screen. Unity will regenerate the App and UWP folders and I think that should include the new Capabilities that you changed.

    It might also work to change them independently in Visual Studio, but personally I prefer to regenerate when multiple code and project editors are involved if you have not added any special UWP code exclusively after the Unity Build process that you are trying to protect.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

Answers

  • HoloSheepHoloSheep mod
    Accepted Answer

    @evanjames in Unity, from the menu go to:
    Edit > Project Settings > Player
    In the Inspector window from the tab with the Windows Store icon:
    Expand the Publishing Settings section and scroll to the bottom area where you see the Capabilities list and look for:

    • InternetClientServer
      make sure that option is checked...

    Then rebuild from the Build Settings window and then deploy from the Visual Studio Solution.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • evanjamesevanjames
    edited May 2016

    @holosheep
    This answer was helpful but I'm still getting the same error on my HoloLens.

    "Capability 'internetclient' is require please enable it in package.manifest because you are using WWW functionality"

  • @evanjames can you share a little more background about what project you are trying to run, your dev environment and what steps you have taken up to the point where you see this error?

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • HoloSheepHoloSheep mod
    Accepted Answer

    @Jesse_McCulloch said:
    it never updates the package.manifest even if you make changes that should update it in the unity side.

    @evanjames if as @Jesse_McCulloch says is true and some bug is preventing the setting from being updated, one easy work around would be to delete the Unity generated App and UWP folders:

    and rebuild from Unity's Build Settings screen. Unity will regenerate the App and UWP folders and I think that should include the new Capabilities that you changed.

    It might also work to change them independently in Visual Studio, but personally I prefer to regenerate when multiple code and project editors are involved if you have not added any special UWP code exclusively after the Unity Build process that you are trying to protect.

    Windows Holographic User Group Redmond

    WinHUGR.org - - - - - - - - - - - - - - - - - - @WinHUGR
    WinHUGR YouTube Channel -- live streamed meetings

  • evanjamesevanjames
    edited May 2016

    @HoloSheep I went back to unity project setting >enabled internetclient and rebuilt.
    Worked! now I have another issue trying to give command to a animation.

  • I would just like to second this solution. I was having the same problem and deleting the App and UWP folders fixed my issues as well, since I enabled the InternetClient and InternetClientServer flags after I had already built the project.

    Thanks!

Sign In or Register to comment.