Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Near Clip Plane setting is not correctly applied in Unity 5.6.2f1.

Anyone succeed to set Near Clip Plane correctly in Unity?
When I set near clip to 0.01, it looks like forced to 0.3 in immersive headset (AH100).
It seems that the Home has nearer clip than 30cm, so I think it should be possible.

Thanks.

Tagged:

Answers

  • Hello,

    First of all, it’s recommend to use Unity MRTP(Unity Mixed Reality Technical Preview), please use it to avoid any impact from developer tool.
    See more details from “Unity Mixed Reality Technical Preview” from here.

    Then in the official site it suggests the following:
    “For mixed reality applications targeted to immersive headsets, it’s suggested to use default setting:
    With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and keep the Near Clip Plane field to the default 0.3”
    Do you have any specific reason to use “0.01”? It does not seem like a reasonable value here.

    It seems that the Home has nearer clip than 30cm, so I think it should be possible.

    There are so many things which are black-box to us.
    1. No sure if the “Home” you mentioned is the default Home scene.
    2. When you can see something very near, it does not mean the camera is directly less than 30cm. We do not know anything about the object. The model itself has a size but we have no idea about its size. Possibly the object is very large so you feel like you are so near to your target. If you mean this, I think it doesn’t mean the clip is <30cm.

    Best regards,
    Barry

  • Hello Barry,

    First of all, it’s recommend to use Unity MRTP(Unity Mixed Reality Technical Preview), please use it to avoid any impact from developer tool.

    OK, I will request Microsoft for Unity MRTP.

    Thanks,
    Yoshitaka

  • If we use the Unity MRTP, does that mean that we can adjust the near clipping plane? I'm using Unity 2017.2 beta, and this does the same thing for my Acer headset - ie. I setting the near clip plan to 0.01 doesn't work properly in the device. Objects start to stop rendering way earlier than expected, which isn't great if you're trying to really get in close and look at something.

    With an Immersive (Virtual) Reality headset, I feel the near clip plane should be almost non-existant. This is possible in Unreal projects for the Rift/Vive, it'd be great to have this support for Unity projects and Windows headsets :smile:

    Thanks!
    Kyle

  • @Penrose_Kyle - The MRTP has been superseded by 2017.2.0b* at this point, so you are already using the correct version. I would check to see if there are any scripts you are using that is overriding the clipping plane at runtime. Without knowing what your project looks like, it's hard to determine what is happening. If you are using any of the prefabs that Microsoft has released, that is likely the culprit. I'd be happy to discuss in further detail if you like.

  • For example, if you are using the Mixed Reality Camera Prefab, there is a script attached to the camera called the MixedRealityCameraManager that helps determine if you are using an occluded HMD or a HoloLens, and set things accordingly. One of these settings is the Near Plane Clip, which is set to 0.3. This is used at runtime, so even if you set the Near Plane Clip to 0.1 on the camera itself, at runtime it will get set to 0.3. I suspect this may be what you are running into, but that is assuming you are using the Mixed Reality Camera in your project.

  • Jimbohalo10Jimbohalo10 ✭✭✭
    edited July 2017

    @Yoshitaka said:
    Hello Barry,

    First of all, it’s recommend to use Unity MRTP(Unity Mixed Reality Technical Preview), please use it to avoid any impact from developer tool.

    OK, I will request Microsoft for Unity MRTP.

    Thanks,
    Yoshitaka

    @Yoshitaka and @BarryWang Like @Jesse_McCulloch stated please use Unity 2017.2.0b , The MRTP has been superseded. Microsoft were never able to supply this!

  • To be fair, they did supply it to a limited set of developers who had very early access to the Acer headsets. It was never released to the public before the API was rolled into the 2017 beta.

  • edited July 2017

    Hey @Jesse_McCulloch , thanks for replying!

    I've experienced this on several different projects and versions, so I just made a new project in Unity 2017.2.0b4 and attached it to this post. It's just a few cubes and the minimum settings to run Windows Mixed Reality for the Acer headset. I set the near clip plane to 0.01 and it definitely appears to be cliipping well before that.

    I haven't actively tried to use the MixedRealityCameraManager component, unless it's getting added automatically and I'm unaware of it. Below are my Camera and Build Settings, they're pretty much the only things I've changed aside from adding some cubes to a level.

    Thanks!
    Kyle

    EDIT:
    After messing around with this a bit more, I think it might actually be rendering the near clip plane correctly based on where the headset is in real world space. HOWEVER, It's doing it at the FRONT of the headset, which is a few inches in front of my eyeballs, and that's making is seem like things are clipping earlier than expected. Is there a way to move the rendering frustum back a few inches from the front of the headset?

Sign In or Register to comment.