Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Sending a simple text string to Hololens

I've been trying to get the UNet sharing examples to work. In fact I've been trying to get connections to the Hololens to work for a couple of days. So far I've tried:

  • UDP server/client (UWP). Works flawless in Windows 10 and other devices.
  • UNet dito. Also works fine on other devices.
  • HoloToolkit SharingTest scene with autodiscover (on device and on localhost)
  • I have tried on multiple routers, even with the server running ON the router itself.

The ONLY thing that works seems to be the SharingTest scene IF I disable Auto Discover Server setting and fill in a specific IP address. However I still cannot recieve anything.

But that is not what I need. I need a flexible system hence me trying to get a UDP broadcast working.

All Capabilities are set and no firewalls are interupting. On ALL of the above I can clearly see the packets on the network.

This makes me wonder if there is a firewall blocking on the Hololens? I'm on the way of giving this up. It seems the Hololens does in fact not follow the UWP standard. Can anyone point me in the right direction?

Better yet: if someone here has WORKING code to send a simple string to the Hololens I would be very happy if you could share this as all my attempts have failed to please this hardware (although it works just perfect in other UWP devices).

Tagged:

Answers

Sign In or Register to comment.