Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

FindPlanes not finding planes

I have very particular problem. I'm using SpatialMapping to scan a room mesh which is then saved to a file using SimpleMeshSerializer. The said mesh is then loaded every time I run the app.

Now, nothing wrong with this, the mesh is saved and loaded without any problems. But when I try to run FindPlanes on it, it returns 0. I've tried debugging the meshes that gets sent to the DLL and cannot see anything strange in them. If I run the FindPlanes right after scanning the mesh, it works without problems.
I tried messing with the DLL by adding MinimumPlaneSize instead of using the constant but that doesn't affect anything.

Could there be something in the save/load that corrupts my data or does the FindPlanes require somehow pre-processed mesh? The example from HoloToolkit uses fbx-files.
Any ideas?

Sign In or Register to comment.