Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Unity Build errors - 2017.20b4 and Mixed Reality Academy -250

My Acer dev kit came in yesterday and I am trying to get same project we did at Build to compile here as a starting point.

Once I get through the setup process and hit build. It appears to work correctly, first creating the assemblies and then moving on to "Creating Visual Studio Solution". When the progress bar disappears, instead of an explorer window appearing after about 3 seconds the following messages appear in Unity. And the App folder remains completely empty.

I am on VS 2017 Community - Unity version 2017.20b4 - SDK version 16232 - Windows Insider Release 16241

Any suggestions?

Best Answer


  • I did the 250 Academy session at Build and it was rather simple, so apparently, there is something going on with the version of something.

    I am on Windows Insider preview build 16241.rs_prerelease
    Windows 10 SDK Version 16232
    I have tried both Unity version 2017.20b2 and 2017.20b4 - same error

    Here are the 3 errors I get. During the "Creating Visual Studio Solution" phase of the build process it stops and these 3 errors appear.

    KeyNotFoundException: The given key was not present in the dictionary.
    System.Collections.Generic.Dictionary`2[System.String,System.String].get_Item (System.String key) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Collections.Generic/Dictionary.cs:150)
    MetroCSharpVisualStudioSolutionCreator.WriteSolutionFile (System.String solutionFileName, UnityEditor.Scripting.ScriptCompilation.ScriptAssembly[] csharpAssemblies) (at C:/buildslave/unity/build/PlatformDependent/MetroPlayer/Extensions/Managed/MetroCSharpVisualStudioSolutionCreator.cs:166)
    MetroCSharpVisualStudioSolutionCreator.CreateSolutionFileFrom () (at C:/buildslave/unity/build/PlatformDependent/MetroPlayer/Extensions/Managed/ExtensionModule.cs:142)
    UnityEditor.WSA.BuildPostprocessor.PostProcess (BuildPostProcessArgs args) (at C:/buildslave/unity/build/PlatformDependent/MetroPlayer/Extensions/Managed/ExtensionModule.cs:149)
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

    Build completed with a result of 'Failed'
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

    UnityEditor.BuildPlayerWindow+BuildMethodException: 2 errors
    at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x00207] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:172
    at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00050] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:83
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

  • That did it. Thanks Jesse

  • ahalimahalim ✭✭

    Yeah the "c# projects" currently does nothing. You can still build the project but won't be able to debug it (put breakpoint, single-step etc.)

  • I've another error during, in Visual Studio this time, lets continue thread here:

  • Jesse could you post a picture?
    I can't find the C# Projects box in the Unity Build Settings Screen

  • I have a number of spatial mapping errors and Not able to set a anchor. My post is here https://forums.hololens.com/discussion/9406/mixed-reality-250-spatial-mapping-errors#latest

Sign In or Register to comment.