Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Different Near Clip Planes in Unity Editor and running in Visual Studio

Hey all!

I'm making a project for the Immersive Headset (Acer), and I have an issue where the near clipping plane is different when I run in editor vs. making a build a running in Visual Studio. I will post repro steps below, as well as screen shots of some of the Unity settings.

I set the near clip plane on the Unity camera to be 0.01, so we can get close to the action.
Running in editor, the near clip plane is close the user's head, while making a build causes the near clip plane to be quite a bit further away. This causes objects to start clipping/disappearing quite far away in a VS build and is a huge problem for us. It kind of seems like somewhere in the build the system might be thinking this is a HoloLens and upping the near clip plane by force? Does that even make sense?

I'm currently running on the Acer headset, Windows Insider Fast flight, latest SDK, Unity 2017.2.0b4, and Visual Studio Community 2017. I've created multiple projects and they all appear to do this.

Repro Steps:
1) Download the attached project
2) Open the Mixed Reality Portal
3) Open the project with Unity 2017.2.0b4
4) Make a build for UWP (File -> Build) . Make sure the build settings match the below screenshot if they got changed.
5) Close Unity, Open the WindowsVRTest.sln file that was just created in VS Community 2017
6) In the play bar at the top, choose Debug, x64, and Local Machine
7) Click the green Play Button, view the project in your headset
8) Move your head towards the cubes until they start disappearing
9) Observe - Objects start disappearing quite far away from the headset.
10) Stop playing, re-open Unity and the project
11) Hit the Play button in Unity
12) Move your head towards the cubes until they start disappearing
13) Observe - Objects start disappearing much closer to the headset

Note: The repro steps are a bit backwards because I believe you have to make a build and put it on the headset before the Play in Editor feature in Unity will work. Correct me if I'm wrong.

Here are my Unity MainCamera and Build Settings, and Visual Studio Run settings:

@Jesse_McCulloch , I previously talked to you in a different post about this, so I figured I'd make a new post.

Thanks!
Kyle

Sign In or Register to comment.