Hello everyone.

We have decided to phase out the Mixed Reality Forums over the next few months in favor of other ways to connect with us.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

The plan between now and the beginning of May is to clean up old, unanswered questions that are no longer relevant. The forums will remain open and usable.

On May 1st we will be locking the forums to new posts and replies. They will remain available for another three months for the purposes of searching them, and then they will be closed altogether on August 1st.

So, where does that leave our awesome community to ask questions? Well, there are a few places we want to engage with you. For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality. If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers. And always feel free to hit us up on Twitter @MxdRealityDev.

Mixed Reality Portal Opens Then Immediately Closes

I've just attempted to get setup for the first time. I'm intending to use the Mixed Reality Portal in Developer/Simulation mode until I have an immersive headset.

After installing prereqs per the Install the Tools developer article, I proceeded to the Using the Windows Mixed Reality simulator article. After choosing the Setup for simulation choice, I waited while it stated it was installing additional necessary packages.

At some point, the window just went away. I eventually tried to relaunch the portal. After a brief window display, it again went away. I then rebooted and tried again. Still no luck. Each time I attempt to launch, it just shuts down. No message is provided.

I checked the Event Viewer and I can see an Application Error is reported:
Faulting application name: MixedRealityPortal.exe, version: 10.0.16251.0, time stamp: 0x597311ce
Faulting module name: MixedRealityPortal.exe, version: 10.0.16251.0, time stamp: 0x597311ce
Exception code: 0xc0000409
Fault offset: 0x0000000000016542
Faulting process id: 0x34c4
Faulting application start time: 0x01d30bcb69fa4967
Faulting application path: C:\Windows\SystemApps\Microsoft.Windows.HolographicFirstRun_cw5n1h2txyewy\MixedRealityPortal.exe
Faulting module path: C:\Windows\SystemApps\Microsoft.Windows.HolographicFirstRun_cw5n1h2txyewy\MixedRealityPortal.exe
Report Id: b8cec6cf-c98c-4c44-bcab-1397bb0c236a
Faulting package full name: Microsoft.Windows.HolographicFirstRun_10.0.16251.0_neutral_neutral_cw5n1h2txyewy
Faulting package-relative application ID: App

Is this a unique issue for me, or does it fit some known problem with some specific steps to resolve?

Answers

  • I think you were using windows preview 16251 which is known to cause this issue to certain computers. Try to use 16241. I tried both and only 16241 worked for me.
    MRP actually throws exception. If you setup post midterm debugging you can get the stack trace.
  • I've updated to build 16257 and now the portal is opening. My headset has arrived now, but unfortunately the portal is not detecting it (though its in the device manager).

  • Updated usb 3.0 drivers and restarted and seems to detect it now, but get "Something went wrong, and we couldn't start Windows mixed Reality"

  • @WizZifnab said:
    Updated usb 3.0 drivers and restarted and seems to detect it now, but get "Something went wrong, and we couldn't start Windows mixed Reality"

    Once you had Simulator mode open, a re-install is needed as special software is loaded. Got to Windows Settings and click "uninstall" Mixed Reality portal Restart PC. Then connect the headset.

    Not sure if you will have same problem as described here, but make sure you are using the USB 3.0 (BLUE inside) socket.

  • Not sure I'd say that Mixed Reality Simulator ever opened. Also, Mixed Reality is not visible to me in settings. So not really finding a way to uninstall it.

    However, I think my issue is possibly the ASMedia issue described here: https://developer.microsoft.com/en-us/windows/mixed-reality/immersive_headset_support#mixed_reality_portal_setup_doesn.E2.80.99t_work_after_turning_on_developer_mode

  • @WizZifnab - There was also an issue with the Mixed Reality Portal in that build of Windows, where it would launch and close immediately, which is what it sounds like you are describing. This is fixed in 16257, which is available in the insiders fast ring.

  • Just following up now...at some point updates resolve my issues and seems to be starting/working without any issues now.

Sign In or Register to comment.