Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Error running the holograms 100 sample

When i try to run on my acer headset i get this error ( I use vs2017 + unity patched )
The program '[15280] holocube.exe' has exited with code -1073741819 (0xc0000005) 'Access violation'.

Module information:
Built with Compiler Ver '190023918'
Built from '2017.1/patch-release' branch
Version is '2017.1.0p2 (31954117ff6c)'
Release build
Application type 'D3D11'
Used 'UWP'

Answers

  • Unity 2017.1 does not have the Mixed Reality SDK in it. You need to be on at least 2017.2.

    Also, what build of Windows are you on?

  • TonyLeoneTonyLeone
    edited August 2017

    Hi @Jesse_McCulloch , after your tips i reinstalled all the environment with : Windows 10 pro fast ring insider preview 16257, then visual studio 2017 community edition 15.2(26430.16) + windows insider preview sd 16257 + unity beta 2017.2.0b6 + unity metro support...I can run from unity directly on the PC, I can build for visual studio and generate the solution, then I opened the solution in visual studio and run the project with x86-device-debug..i can see the cube on the screen...After that i tried to run with acer headset connected and mixed reality portal open but I cannnot see anything in the display. The only app strange that i see in the start menu is uinoentrypoint.design...i i try to launch this app i see only a blank window in the headset with the progress ring active...If I return in Visual studio the app generate one exception regarding access violation. see image below.

  • What graphics card are you using @TonyLeone?

  • nvidia geforce gt 750M...another info...if i run the same app from visual studio but in release x86 run without debug...in the headset i can see the teleport in the new app and after that only a black screen with a white dot in a fixed position.

  • Can you submit this via the feedback hub so Microsoft can get the telemetry. I've heard of this happening to others. This may be the same issue that @LocalJoost is running into, I can't remember for sure.

    Here is a little high level info about reporting feeback via the hub - https://forums.hololens.com/discussion/8144/providing-feedback-effectively

  • another little step...if i run directly from unity with mixed reality portal active and headset connected i can see the cube of the hologram 100 sample ... only with visual studio i see a blank dot point in the application. I will report in the feedback hub, thanks for the help.

  • XR: Windows Mixed Reality usage on b7 results in hangs and black screens at start-up. This has been fixed in b8 for VR HMDs, but is still an issue for HoloLens.

Sign In or Register to comment.