Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Problem with Unity Network Manager and HoloLens

Hi all,

I'm developing an Asymmetrical multiplayer application for HoloLens in Unity using the inbuilt Network Manager. I'm running into the problem that the application works fine on multiple PCs and in Unity both with and without holographic emulation, but it's not working at all on the HoloLens or HoloLens Emulator. The application starts, but when it tries to connect as a client nothing happens. I have InternetClientServer and Private NetworkClientServer checked off, so I'm not sure what else I'm missing. I read one post that said I may need to put my prefabs in a resource folder somewhere, but I have no idea where this folder should go.

Any help is appreciated.

Tagged:

Answers

  • The Mixed Reality 250 project uses UNET to communicate between HoloLens and Windows. I would strongly encourage you to grab the 250 project and look at the debug panel. The implementation is pretty light so you should be able to drop it into your project and visualize the debug spew.

    The resources folder is likely a red herring. I rarely use a resources folder, and the MR250 project doesn't have one despite spawning many prefabs. I think you need that for the Resources.Load<> API.

    Off the top of my head, things that could be going wrong:
    1. You have some object in your scene that is a network behavior, but doesn't have a network ID. I saw this happen recently, and the behavior is just as you described. It worked for everything, including play to HoloLens from unity, but did not work for HoloLens on device or emulator.
    2. You have a scene object that you are spawning which isn't in the spawnable prefabs list on the network manager. I made this mistake in the MR 250 project, and everything somehow worked until a Unity update exposed my bug. #Embarrassed
    3. Some network infrastructure is getting in your way. When we were setting up for build this year our fancy industrial routers thought the traffic coming from the app was suspicious, and cut traffic from HoloLens devices.

    ===
    This post provided as-is with no warranties and confers no rights. Using information provided is done at own risk.

    (Daddy, what does 'now formatting drive C:' mean?)

  • Cheers, I'll run through these 3 when I'm back from lunch and take a look at the 250 course.

Sign In or Register to comment.