Hello everyone.

The Mixed Reality Forums here are no longer being used or maintained.

There are a few other places we would like to direct you to for support, both from Microsoft and from the community.

The first way we want to connect with you is our mixed reality developer program, which you can sign up for at https://aka.ms/IWantMR.

For technical questions, please use Stack Overflow, and tag your questions using either hololens or windows-mixed-reality.

If you want to join in discussions, please do so in the HoloDevelopers Slack, which you can join by going to https://aka.ms/holodevelopers, or in our Microsoft Tech Communities forums at https://techcommunity.microsoft.com/t5/mixed-reality/ct-p/MicrosoftMixedReality.

And always feel free to hit us up on Twitter @MxdRealityDev.

Build errors when I try to build a simple unity project

I get these errors on trying to build the visual studio solution generated by unity:

I'm using Unity 2017.1.0p4 and Visual Studio Professional 2017 version 15.3.3, all that's in the project is a cube, and VR supported (Windows Holographic) is enabled in Unity.

I've made sure "Automatically check for missing packages during build in Visual Studio" is checked, and I've tried repairing my Visual studio install 3+ times.

I've spent all morning trying to get this to work, any help would be greatly appreciated!

Thanks in Advance!


  • Update Unity to 2017.1.0p5, I had this issue earlier.

  • mHarris,

    From the error, I think you are trying to build a debug project? This may not be working with Unity 2017.1.x. Try building release or master instead. If you really need debug (who doesn't?) you might consider downgrading to 5.6.3p2 instead.

    James Ashley
    VS 2017 v5.3.3, Unity 2017.3.0f3, MRTK 2017.1.2, W10 17063
    Microsoft MVP, Freelance HoloLens/MR Developer

  • Thanks for your responses,

    Tried both of these things, I get the same errors with both :(

    Might try completely reinstalling both VS and Unity

  • I tried reinstalling vs and Unity, that didn't help. Then I tried using the build window included in the HoloToolKit, and this works.

    I really don't understand what's going on here, surely both visual studio and HoloToolKit are using MSBUILD, so should give the same result?

Sign In or Register to comment.